Cannot have jessyink work on inkscape 0.48

Asked by Franck on 2011-09-18

Hi,

could you confirm that the pre-installed version of jessyink in inkscape 0.48 work?
I've followed the tutorial http://www.timteatro.net/2010/08/12/a-tutorial-introduction-to-jessyink-presentations-in-inkscape/ without success.
Firefox 6 displays all my SVG layers at once (the file contains jessyink's javascript) and I cannot get any slideshow.
My config:
- Ubuntu 11.04
- Inkscape 0.48.1 r9760

Thanks!
Franck

Question information

Language:
English Edit question
Status:
Solved
For:
JessyInk Edit question
Assignee:
Hannes Hochreiner Edit question
Solved by:
Franck
Solved:
2011-09-18
Last query:
2011-09-18
Last reply:
2011-09-18

Hi Franck:

I have received reports that some files in the Debian/Ubuntu package are broken due to a well-meant but ultimately detrimental change during packaging. The issue concerns a hash-pound line that was added and that leads to an error when the JavaScript is interpreted (see also bug #852018). A possible fix for the problem is to remove the offending line in a text editor. I don't know whether that is the problem you are having, but it might be. If you could post an example file somewhere where I can have a look at it, I would be happy to do so.

Cheers,
Hannes

Franck (amail4-franckinsc) said : #2

Hi Hannes,

thanks for the swift reply. It was indeed the bug. I've removed #!/usr/bin/env js and it works fine now.

Cheers,
Franck