rasterize effects when exporting in pdf

Asked by alain on 2010-03-02

Hi,

thanks a lot for jessyInk. I use inkscape since 2 years and often think about making presentation whith it. And now, i can!
I have some trouble when exporting in pdf, shaded effects are ugly. With the standard pdf export of inkscape, i can chose to rasterize effects, which give a nice result. I'm not a specialist in using svg and python but i'm sure that there is an easy way to acces to the standard export options when using the "zipped pdf output" module. Do you have some tips?

thank you

Alain

Question information

Language:
English Edit question
Status:
Solved
For:
JessyInk Edit question
Assignee:
No assignee Edit question
Solved by:
Hannes Hochreiner
Solved:
2010-04-06
Last query:
2010-04-06
Last reply:
2010-04-02
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Hi Alain!

Sorry for the delay. I have been on vacation and I tried to comment on your question by e-mail, but apparently it did not work.

Anyway, the way the output works is that it uses Inkscape via the command line. I have to check, if there is a command line option that allows rasterisation of effect for the export. If so, it should be a quick fix. I'll keep you posted on my progress.

Cheers,
Hannes

alain (sauter-a) said : #3

Hi Hannes,

thank you for your interest. For the moment, I avoid using shaded effects :) . I have looked with our developper Ing. around command line and it seems that there is no special option for rasterisation of effect. Maybe we have to wait the next inkscape version...
So, thanks to have a look, but do not spend too much time if there is no quick fix.

Cheers,
Alain

Hi Alain:

I just checked "man inkscape" for command line options. It seems that by default object with effects should be rasterised:

" By default, all filtered objects are rasterized at --export-dpi
  (default 90 dpi), preserving the appearance. "

I tested it with a simple square with some blur and it seemed to come out ok in the PDF. I was using Inkscape 0.47 on Ubuntu.

Which version of Inkscape are you using?

Cheers,
Hannes

alain (sauter-a) said : #5

Thanks Hannes Hochreiner, that solved my question.

alain (sauter-a) said : #6

Hi Hannes,

i also use inkscape 0.47 on Ubuntu, and i've seen that the export had rasterized my effects. The pdf seems to be good with a small size effect, but 90dpi is not so good for a presentation aroud 1280*1024 with biggest effetcs. For the moment, i let jessyink producing my pdf and then re-export ( with "save as / pdf / rasterize effects 300dpi" ) the few layers wich contains biggest effects.

Thanks for your interest!

cheers

Alain

Hi Alain:

Sorry, I think I partly misunderstood your question. I thought it was about rasterizing the effect at all, not so much about the resolution. Since I am about the rewrite the export extension anyway, I will put in an option for the resolution.

Cheers,
Hannes

alain (sauter-a) said : #8

Hi Hannes,

Don't worry. :)
An option for the resolution will definitively put jessyink on top and give me some more arguments to convience my collegues.
Thanks!

Alain