php53u and php54 gd libjpeg requirements

Asked by Jeffrey Ness on 2013-03-25

Redhat and CentOS 6.4 has introduced a new package to the ecosystem,
and obsoleted an old one. The package is libjpeg-turbo which obsoletes

    # cat /etc/redhat-release
    CentOS release 6.4 (Final)

    # yum install libjpeg

    Resolving Dependencies
    --> Running transaction check
    ---> Package libjpeg-turbo.x86_64 0:1.2.1-1.el6 will be installed
    --> Finished Dependency Resolution

    Dependencies Resolved

     Package Arch Version Repository Size
     libjpeg-turbo x86_64 1.2.1-1.el6 base 174 k

    Transaction Summary
    Install 1 Package(s)

    Total download size: 174 k
    Installed size: 466 k
    Is this ok [y/N]:

With this new package the LIBJPEGTURBO_6.2 provider was added:

    # rpm -q libjpeg-turbo --provides | grep

What this means is packages that are built off libjpeg-turbo will have this
requirement. Such packages are the php54-gd and php53u-gd package
as IUS builds off the latest available base repository:

    # rpm -q php54-gd --requires | grep

If you are experience missing dependencies for libjpeg be sure you fully up to
date on the latest Enterprise Linux version (as of this written this would be

Question information

English Edit question
IUS Community Project Edit question
No assignee Edit question
Last query:
Last reply:
Jeffrey Ness (jeffrey-ness) said : #1

Answer above

Can you help with this problem?

Provide an answer of your own, or ask Jeffrey Ness for more information if necessary.

To post a message you must log in.