Mono compatible?

Asked by anyway on 2010-03-02

Hello, is this library MONO compatible?
Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
IRC.NET Edit question
Assignee:
Alexander Regueiro Edit question
Last query:
2010-03-02
Last reply:
2011-06-24
Alexander Regueiro (alexreg) said : #1

Mono support is actually something I've been looking into recently. It seems that the library refuses to compile on Mono 2.6.1 due to several (minor) missing parts in the class library, though I have tested compilation against Mono 2.7 (trunk) and it seems to at least compile nicely. At the moment however I'm having a few problems getting Mono to run my sample app (it won't even launch, so there's possibly a Mono bug somewhere), so I can't verify whether it runs perfectly well yet, though in theory it should.

So in summary, the answer is 'yes' (for Mono trunk). If you want to give it a go yourself, I'd be happy to provide what assistance I can. Let me know of the results either way please.

Alexander Regueiro (alexreg) said : #2

Solution given.

anyway (gosustyle87) said : #3

Good job. :)