cannot rotate or scale fill pattern

Asked by nigel

When I fill an object with a pattern I do not get the handles to rotate and scale the pattern as I think I should when the node tool is selected.

To reproduce: create a square; right click it and select Fill and Stroke; select the Fill tab and select the icon with the pattern; select stripes 1:1; click the node tool. Note there are no handles to alter the scale and rotation of the fill as there are when the gradient fill tools are selected.

My version is 0.47 and am running on Ubuntu 9.10 64-bit.

Question information

English Edit question
Inkscape Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
su_v (suv-lp) said :

The handles to scale and rotate a stock pattern are in the upper left corner of the page, you might have to zoom out or pan to find them while the node tool is active.

from the manual:
«Adjusting Patterns is done by a set of handles. The handles will appear when an object with a Pattern fill is selected and the node or one of the shape tools is active. The handles will appear on the original objects that defined the Pattern, or the former location of those objects if they have been moved or deleted (unless the Pattern has been previously adjusted). In the case of built-on Patterns they will appear in the upper-left corner of the canvas. The following figure shows the location of the handles for a Pattern that has not been adjusted. »

Revision history for this message
nigel (nigeldodd-gmail) said :

You are quite right: the handles are there all the time but they were some distance away from the bounding box of the object I was filling. They were on the page boundary. I needed to zoom out to see them. Thank you.

However I now encounter a bug such that fiddling with the handles causes Inkscape to crash. It says it has encountered an internal error and will close. The problem is intermittent and I cannot give you a recipe to reproduce it but it happens on a drawing with two layers, the bottom of which is a bitmap, and happens when I move the pattern rotation or scaling handles and sometimes when I move a node on the filled curve.

Revision history for this message
Best su_v (suv-lp) said :

unfortunately there are several open bugs about node-editing pattern-filled objects in Inkscape 0.47:

see these related bug reports:
Bug #463602 “crash when node-editing pattern-filled object”
Bug #486203 “crash when pattern-filled ellipse is manipulated with node tool”
Bug #429050 “segfault when filling with pattern”
Bug #271723 “Segmentation Fault (crashes) when I try to move a large pattern”

Revision history for this message
nigel (nigeldodd-gmail) said :

Thanks ~suv, that solved my question.

Revision history for this message
luojie-dune (luojie-dune) said :

Im having the similar problem, cannot find handle with node tool.