paste stopped working

Asked by DanHeywood

Using Apple OS 10.6.1 (Snow Leopard)

I was working with a file, and at one point the paste stopped working. Not just while working on the one file, but on new files I create too. If I paste the copy in the layer it originated from, all copied paths turn solid pale blue. If I attempt to paste in a new layer, nothing happens. Undo does not indicate a paste was attempted, and the status bar doesn't indicate any pasting is being attempted. I attempted to paste with ctrl+P, as well as via the menu (Edit>paste).

This occurs on both 0.47pre3 and 0.47pre4 on Snow Leopard.

To emphasize, paste was working, then suddenly stopped. However, I took the file over to another computer with a 0.46 copy on Apple Tiger (OS 10.4), and paste works fine there.

Any ideas?

Question information

English Edit question
Inkscape Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
DanHeywood (heywood-photography) said :

Oops, I meant I attempted to paste via ctrl-V, not ctrl-P ;)

Revision history for this message
Best su_v (suv-lp) said :

Did you change the clipboard preferences of X11/Xquartz according to the FAQ?
Screenshot of the X11 preferences window: <>

If this doesn't help, please consider adding a comment to the most recent bug report about problems with the X11 clipboard on Snow Leopard (if you have additional information that could be helpful to triage these apparently Snow Leopard or Xquartz 2.3.4 specific issues):
Bug #460197 in Inkscape: “Can't copy objects in pre4, Snow Leopard”

Revision history for this message
DanHeywood (heywood-photography) said :

That worked, thank you! Although, I am confused as to why paste did work (even before I unchecked "Update Pasteboard when CLIPBOARD changes" in preferences), and then stopped working.

Thanks again!

Revision history for this message
DanHeywood (heywood-photography) said :

Thanks ~suv, that solved my question.

Revision history for this message
su_v (suv-lp) said :

Paste worked but it always inserted a bitmap copy not vector information (i.e. a link to a PNG file stored somewhere on your disk, be it in the current working directory, your home folder or - worst case - inside the application bundle of Inkscape in earlier versions) - check your old files. If that wasn't so, something must have changed in Snow Leopard's Xquartz version we currently aren't aware of ;-)

It is odd though and IIRC has been reported three times up to now with Inkscape Inkscape 0.47(pre) that even the basic copy&paste on Snow Leopard X11/Xquartz 2.3.4 stopped working, but this certainly seems like an issue upstream (not in Inkscape) that should be discussed with the developers of X11/Xquartz in the X11-users mailing list or on reported on the Xquartz bug tracker <>. I never experienced it with Xquartz 2.4.0 on OS X 10.5.8 Leopard though I have the same problem as described in the FAQ.