How to embed fonts in Inkscape?

Asked by Sandro on 2009-09-23

Hi All,

I routinely transport my Inkscape files from one computer to another [house / office] but the office computer does not have all the fonts I have at home, so when I load my Inkscape files on it, it replaces the fonts and that messes up my designs.

Is there a way to embed fonts in an Inkscape file?

I do not want to convert the fonts to paths nor objects because I could want to change the text.

Thanks!

Question information

Language:
English Edit question
Status:
Answered
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2009-09-23
Last reply:
2012-10-15
su_v (suv-lp) said : #1

Not yet ;-)

There has been initial support for SVG fonts added for 0.47:
<http://wiki.inkscape.org/wiki/index.php/Release_notes/0.47#Initial_SVG_Fonts_support>
but at the moment you can use it only to design fonts, not embed those used in text objects AFAIU.

related links:

Fonts - SVG 1.1 - 20030114:
<http://www.w3.org/TR/SVG11/fonts.html>

Bug #170963 in Inkscape: “Support for SVG fonts (rendering, embedding,...)”:
<https://bugs.launchpad.net/inkscape/+bug/170963>
Questions : Inkscape: How to create font with SVG Fonts dialog
<https://answers.launchpad.net/inkscape/+question/59676>

Subject: designing fonts within Inkscape
<http://article.gmane.org/gmane.comp.graphics.inkscape.devel/28511>
Subject: SVG Font Editor
<http://thread.gmane.org/gmane.comp.graphics.inkscape.user/12337>

hth, ~suv

Alex (cardigan99) said : #2

Is there any progress on this issue?

I needed to embed a font into an SVG and saw this. Then I googled around and figured out how to do it manually. Here's how:

First, the syntax:

http://graphicdesign.stackexchange.com/questions/5162/how-do-i-embed-google-web-fonts-into-an-svg

<style>
  @font-face {
    font-family: "Sample font";
    src: url("data:font/woff;charset=utf-8;base64,...");
  }
</style>

(this tag can go right at the top of the SVG, after the <SVG> opening tag)

To perform the base64 encoding in Ubuntu:

:~$ base64 GOTHIC.TTF | tr -d '\n' > gothic.b64

piping into tr is necessary to trim the newline characters

http://ubuntuforums.org/showthread.php?t=1132578

base64 -w 0 GOTHIC.TTF > gothic.b64

The same - option -w 0 turns off wrapping

Can you help with this problem?

Provide an answer of your own, or ask Sandro for more information if necessary.

To post a message you must log in.