INKSCAPE sodipodi: prefix

Asked by aquis

I am using a pre-created SVG file which contain inside some <g id="grp_ref" onclick="parent...." onmouseover="...

I provide to some users the possibility to download these svg's and to modify them on their computer using inkscape... than I offer them to upload the file back, but when they are saving the file as inkscape svg these sodipodi: is added in front of different attributes and the file will no longer validate with svg-validator-1.0....

How to manage to make inkscape not add these sodipodi: in front of attrin's ?

with kind regards


Question information

English Edit question
Inkscape Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
RIco (rico-rootscore-deactivatedaccount) said :

save your file as "plain svg" instead of "inkscape svg".

Revision history for this message
aquis (office-talente) said :

Hi Rico

The main problem with save as PLAIN SVG is the fact that the command is removing javascript code attached to edlements: onclick="..."
 and that is not what I want.

For the moment I've solved my problem temporarily with php xml traversing of te attributes and removing of the ones which starts with sodipodi: but it would be nice to see a option don't add sodipodi namespace to eleents, somewhere in the SETTINGS menu inside inkscape.

With kind regards lokiing to hear your oppinion about this setting


Revision history for this message
RIco (rico-rootscore-deactivatedaccount) said :

For now I think the only way would be as you did, the use of a script.
You could post it as a "wish-list" on the bugs section to have the developers eventually include the option in inkscape.

Can you help with this problem?

Provide an answer of your own, or ask aquis for more information if necessary.

To post a message you must log in.