Inkscape 1.1-dev does not have Save_as / Optimized SVG. Was it deprecated or is it a bug?

Asked by Père Ubu on 2020-02-24

0.92 has Save as / Optimized SVG 1.1-dev does not . Is this meant to be or is it a bug?

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Père Ubu
Solved:
2020-03-09
Last query:
2020-03-09
Last reply:
2020-03-06
Hachmann (marenhachmann) said : #1

It should be available, if scour is installed. How did you install Inkscape and on which operating system?

Père Ubu (todo-ubuntu) said : #2

I am on LinuxMint Tricia 19.3 / Cinnamon 4.4.8 running Inkscape 1.1-dev (1:0.92.0+devel+202002241831+cf8c797)

scour 0.37 is also installed

inkscape is updated daily from the ppa inkscape.dev/trunk

Hachmann (marenhachmann) said : #3

Can you check in your extension-errors.log file in ~/.config/inkscape if it mentions anything about the 'save as optimized svg' extension?

Do any other extensions work? / Are they available?

Père Ubu (todo-ubuntu) said : #4

~/.config/inkscape/extension-errors.log is empty

I created a new blank file and then successfully saved as:
inkscape_SVG
plain_SVG
compressed_inkscape_SVG
encapsulated_postcript
enhanced_metafile
LaTex_with_PSTricks_macros
openDocument_drawing
portable_document_format
postscript
PovRay
Window_metafile

I previously had updated from inkcase.dev/trunk today. Optimized SVG is still missing on my machine

Hachmann (marenhachmann) said : #5

Can you confirm that there are only very few extensions in the extensions menu?

I've just checked the package contents of

https://launchpad.net/~inkscape.dev/+archive/ubuntu/trunk/+files/inkscape-trunk-data_0.92.0+devel+202002251828+2fde448~ubuntu18.04.1_all.deb

and

https://launchpad.net/~inkscape.dev/+archive/ubuntu/trunk/+files/inkscape-trunk_0.92.0+devel+202002251828+2fde448~ubuntu18.04.1_amd64.deb

and can confirm that there are no Python extensions contained in the packages.

Can you please report this packaging issue at https://inkscape.org/report?

Père Ubu (todo-ubuntu) said : #6

Here are the extensions I see:

Generate from path: 1 extension (Inset / Outset Halo)

Raster: 34 extensions

Render: 1 extension (Grid/grid)

will do my best to report the packaging issue. Not too sure what 'no Python extensions' mean. I guess will refer to this discussion.

Hachmann (marenhachmann) said : #8

Thanks! It means that the extensions directory is empty, because the git submodule that provides it is not imported in packaging.

The few extensions that you have are coded in C++, and part of Inkscape's core code. Those that are missing have been forgotten to include.

Père Ubu (todo-ubuntu) said : #9

Hello!

I am still looking for a solution without having to run scour after saving with inkscape.

Do you think compiling the program myself would be an option? I read that this is not an easy task though ...

Is not having included the extension just an oversight or there would be another problem if they were included in a compiled version?

Hachmann (marenhachmann) said : #10

As a temporary workaround, you can just copy the extension files from https://gitlab.com/inkscape/extensions into your user configuration extensions directory (~/.config/extensions).

Hachmann (marenhachmann) said : #11

(i.e. all files and folders in the extensions-master folder in the zip (https://gitlab.com/inkscape/extensions/-/archive/master/extensions-master.zip) must be put into ~/.config/extensions )

Père Ubu (todo-ubuntu) said : #12

Hello Maren,

I really appreciate your timely answer & suggestion, thank you.

However, it did not change much on my system.

I put all contents from extensions-master.zip from the link into ~/.config/extensions, then re-started inkspace, open a new document, 'save as' gives me the same extensions choices as previously, and still no optimized SVG ...

Is that what I was supposed to do?

Hachmann (marenhachmann) said : #13

It worked for me... What does the log file say now? Did the number of available extensions increase significantly in the extensions menu?

You can also try to put them into /usr/share/inkscape/extensions/ instead (remove from your personal config again before you do that). That won't survive an update of Inkscape, though, and as you're using daily builds ...

Père Ubu (todo-ubuntu) said : #14

It did it again and it did work, using your correct first suggestion of populating ~/.config/extensions.

Yesterday I had not correctly renamed the extensions-master after dragging it into ~/.config. Very sorry about that and many thanks again for putting up with me going through this.

For completeness, still nothing in the log file, which might be a good thing. Also, having my system going, I did not try the /usr/share/inkscape/extensions/ either.

Last thing: the work-around does work but is the problem solved? I don't feel experienced enough on how this team operates to push the 'Problem Solved' button. Will gladly do it if you advise going this way.

Hachmann (marenhachmann) said : #15

Great :D

There's nothing else I can help you with here, the bug report you made is the thing that needs to be solved. I've tagged the persons who could potentially fix it, but aside from that, ... we need to wait.

The 'Solved' label is maybe useful for users looking for information about that identical issue, aside from that, it doesn't really matter.

Père Ubu (todo-ubuntu) said : #16

Alright, maximum κῦδος (kudos) to you for solving this and for a prompt, clear, and diligent follow-up! Cheers!!!

Père Ubu (todo-ubuntu) said : #17

#10 & #11 solved my problem.

# 10
As a temporary workaround, you can just copy the extension files from https://gitlab.com/inkscape/extensions into your user configuration extensions directory (~/.config/extensions).

# 11
(i.e. all files and folders in the extensions-master folder in the zip (https://gitlab.com/inkscape/extensions/-/archive/master/extensions-master.zip) must be put into ~/.config/extensions )