Formatting is lost when I open ai file in Inkscape

Asked by Gavin on 2019-10-11

A graphics designer has created an ai file for me which I need to edit regularly, by inserting barcodes. As all I need to do is insert an image and maybe move it or resize it, I want to use a free product such as Inkscape.

He's given me a pdf version of it and it prints perfectly.

Yet when i import it onto Inkscape, then print, I lose the resolution in the company logo and slogan (which the graphic designer copied from an image I gave him). Also the background colour is a very pale cream colour - it looks cream when imported to Inkscape but is white when printed from Inkscape.

Any help greatly appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Gavin
Solved:
2019-10-15
Last query:
2019-10-15
Last reply:
Gavin (brownbag) said : #1

I tried both import settings - poppler/cairo and internal import.
I also tried changing the "precision of approximating gradient meshes" to very fine.

What was odd was that in each case, the heading of the import settings screen said, "PDF Import Settings". I would expect that when I import an ai file, it wouldn't say "PDF Import Settings".

Hachmann (marenhachmann) said : #2

AI files are pdfs, with an extra binary part.

Ask your designer to give you an SVG file, it's possible to export that from Illustrator.

And ask him or her to use the RGB color space (Inkscape does not support other color spaces).

Gavin (brownbag) said : #3

thanks.