Inkscape / XQuartz won't open and crashes on my Mac

Asked by Theresa Muller on 2019-04-02

I've successfully used Inscape in the past. Don't know what's changed, but it now crashes (yes, even the replacement installation crashes) and gives me the following message:
XQuartz cannot be opened because of a problem.
Check with the developer to make sure XQuartz works with this version of macOS. (I'm using macOS High Sierra Version 10.13.6.) You may need to reinstall the application. (Which I have done.) Be sure to install any available updates for the application and macOS.
This report will be sent to Apple automatically.
(The crash report details are as follows:)
Process: X11.bin [6990]
Path: /Applications/Utilities/XQuartz.app/Contents/MacOS/X11
Identifier: org.macosforge.xquartz.X11
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: X11.bin [6990]
User ID: 501

Date/Time: 2019-04-02 18:23:39.310 +0200
OS Version: Mac OS X 10.13.6 (17G65)
Report Version: 12
Anonymous UUID: 0A650EEE-5A36-8576-23C5-3FDDD2737090

Sleep/Wake UUID: 85CA52F8-3B6A-429F-912F-6847DFEFB490

Time Awake Since Boot: 30000 seconds
Time Since Wake: 1300 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Reason: DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: /opt/X11/*/libAppleWM.7.dylib
  Referenced from: /Applications/Utilities/XQuartz.app/Contents/MacOS/X11.bin
  Reason: image not found

Binary Images:
       0x100000000 - 0x1001b5fff +X11.bin (???) <C155122F-0027-361A-8BCA-A94C2A722F5B> /Applications/Utilities/XQuartz.app/Contents/MacOS/X11.bin
       0x100238000 - 0x10025bff7 +org.andymatuschak.Sparkle (1.6 git - 1.6) <BE5E3396-7A0B-3C4C-8838-A7765B2B0A44> /Applications/Utilities/XQuartz.app/Contents/Frameworks/Sparkle.framework/Versions/A/Sparkle
       0x10bb49000 - 0x10bb93acf dyld (551.4) <8A72DE9C-A136-3506-AA02-4BA2B82DCAF3> /usr/lib/dyld
    0x7fff273cc000 - 0x7fff273ccfff com.apple.Carbon (158 - 158) <F8B370D9-2103-3276-821D-ACC756167F86> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
    0x7fff278de000 - 0x7fff278defff com.apple.Cocoa (6.11 - 22) <78E6C28E-4308-3D10-AD14-0CBCF6789B3F> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
    0x7fff27b32000 - 0x7fff27bc5ff7 com.apple.audio.CoreAudio (4.3.0 - 4.3.0) <EB35D3EC-56EA-33E6-98DC-BDC3A5FA8ACE> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
    0x7fff2a8cf000 - 0x7fff2a96afff com.apple.framework.IOKit (2.0.2 - 1445.71.1) <2EA4F383-CAA9-3AF0-99C5-90C22ADAA6B6> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
    0x7fff32618000 - 0x7fff32627ff3 com.apple.opengl (16.7.4 - 16.7.4) <9BDE8FF9-5418-3C70-8D1C-09656884CE48> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL
    0x7fff4dd02000 - 0x7fff4dd0eff3 libXplugin.1.dylib (47) <99DCDCAD-F7C9-3183-BB09-CA577B087485> /usr/lib/libXplugin.1.dylib

Model: MacBookPro11,5, BootROM MBP114.0184.B00, 4 processors, Intel Core i7, 2,5 GHz, 16 GB, SMC 2.30f2
Graphics: AMD Radeon R9 M370X, AMD Radeon R9 M370X, PCIe
Graphics: Intel Iris Pro, Intel Iris Pro, Built-In
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x802C, 0x31364B544631473634485A2D314736453120
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x802C, 0x31364B544631473634485A2D314736453120
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x152), Broadcom BCM43xx 1.0 (7.77.37.31.1a9)
Bluetooth: Version 6.0.7f10, 3 services, 18 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM0512G, 500,28 GB
USB Device: USB 3.0 Bus
USB Device: Internal Memory Card Reader
USB Device: Apple Internal Keyboard / Trackpad
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: MacBook Pro, Apple Inc., 27.1

PLEASE HELP!?!

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Hachmann
Solved:
2019-04-03
Last query:
2019-04-03
Last reply:
2019-04-02
Best Hachmann (marenhachmann) said : #1

Sorry, I can only guess.

The only idea I would have would be to uninstall both XQuartz and Inkscape, and then to reinstall XQuartz, then reinstall Inkscape.

You need to decide yourself if you want to try this or not. In any case, if you can't get it to work, can you please visit https://chat.inkscape.org/channel/inkscape_user to have a chance to get the reply from someone who regularly works on macOS?

Theresa Muller (theresamuller) said : #2

Thank you! I had only re-installed Inscape before. Following your advice, I downloaded XQuartz, installed it, re-started my laptop and wallah! It is working. Many thanks.

Theresa Muller (theresamuller) said : #3

Thanks Hachmann, that solved my question.

Hachmann (marenhachmann) said : #4

:-) Great! Now when someone else comes with that error message, we know what helps. Thanks for reporting back!