Rendering any latex in Inkscape does not work anymore

Asked by Robin Vogel on 2019-03-28

Since I last upgraded Inkscape 0.92.4 (45b59e7, 2019-03-20), and probably its dependencies (I upgrade everything through apt-get), I cannot render latex anymore.

Indeed, on a new file, using Extensions > Render > LaTeX gives the following error:

```
Error: /undefined in .makeoperator

Operand stack:

   false rectfill rectfill --nostringval--

Execution stack:

   %interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 2044 1 3 %oparray_pop 2043 1 3 %oparray_pop 2024 1 3 %oparray_pop 1884 1 3 %oparray_pop --nostringval-- %errorexec_pop .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval--

Dictionary stack:

   --dict:1234/1684(G)-- --dict:0/20(G)-- --dict:218/300(L)-- --dict:1234/1684(G)--

Current allocation mode is global

Current file position is 14859

GPL Ghostscript 9.26: Unrecoverable error, exit code 1

PostScript/PDF Interpreter finished. Return status 256 executed command : gs -q -dDELAYBIND -dWRITESYSTEMDICT -dNODISPLAY -dNOEPS "/tmp/psinpIcqFd"

The interpreter seems to have failed, cannot proceed !

Traceback (most recent call last):
  File "eqtexsvg.py", line 160, in <module>
    e.affect()
  File "/usr/share/inkscape/extensions/inkex.py", line 283, in affect
    self.effect()
  File "eqtexsvg.py", line 154, in effect
    svg_open(self, svg_file)
  File "eqtexsvg.py", line 81, in svg_open
    doc = inkex.etree.parse(filename)
  File "src/lxml/etree.pyx", line 3426, in lxml.etree.parse
  File "src/lxml/parser.pxi", line 1840, in lxml.etree._parseDocument
  File "src/lxml/parser.pxi", line 1866, in lxml.etree._parseDocumentFromURL
  File "src/lxml/parser.pxi", line 1770, in lxml.etree._parseDocFromFile
  File "src/lxml/parser.pxi", line 1163, in lxml.etree._BaseParser._parseDocFromFile
  File "src/lxml/parser.pxi", line 601, in lxml.etree._ParserContext._handleParseResultDoc
  File "src/lxml/parser.pxi", line 711, in lxml.etree._handleParseResult
  File "src/lxml/parser.pxi", line 640, in lxml.etree._raiseParseError
  File "/tmp/inkscape-UjDLa0/eq.svg", line 1
lxml.etree.XMLSyntaxError: Document is empty, line 1, column 1
```

The Ghostscript version is GPL Ghostscript 9.26 (2018-11-20).

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Hachmann
Solved:
2019-03-31
Last query:
2019-03-31
Last reply:
2019-03-28
Best Hachmann (marenhachmann) said : #1

Can you make this a bug report at https://gitlab.com/inkscape/inbox/issues/ , please?

Robin Vogel (michel-kohlhaas) said : #2

Thanks Hachmann, that solved my question.

I'm also having this same issue

Tony Travia (amtp25) said : #4

I'm tagging this as I too am having this issue. Did anyone find a fix yet?

Hachmann (marenhachmann) said : #5

You can follow the discussion at https://gitlab.com/inkscape/extensions/issues/73