Inkscape slowed down/crashes by importing large SVGs

Asked by jenniferh on 2019-02-26

I am trying to use Inkscape to design a poster. For this I used ggplot to produce svgs (which, to be fair, have a huge amount of datapoints). One svg has about 8Mb.
While importing I have to untick the preview to prevent inkscape from getting stuck. As soon as it is imported (which takes ~1min) I basically am unable to do anything as soon as I try to move the imported svg the window is greyed out and I get the warning:

Warning: limit of 200 snap sources reached, some will be ignored
Warning: limit of 200 snap target paths reached, some will be ignored
Warning: limit of 200 snap target paths reached, some will be ignored
Warning: limit of 200 snap target paths reached, some will be ignored
Warning: limit of 200 snap sources reached, some will be ignored

It sometimes resolves itself but the imported image is not moved.

I really need to import these svgs as the poster is quite huge and I cannot risk the images to be blurry.

Is there anything I can do?

System:
Ubuntu 16.04 LTS 64bit
62,8 GiB RAM

Inkscape 0.92.4
(I upgraded from 0.91 since I thought that might be the issue but even with 0.92.4 I am unable to do anything)

Thanks for your time.

Jenny

Ps: since its not published data I am happy to share a link to the svg privately, but I'd rather not upload it for everyone to see.

Question information

Language:
English Edit question
Status:
Answered
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2019-02-27
Last reply:
2019-02-28
Hachmann (marenhachmann) said : #1

If you don't need snapping, disable it by hitting % or clicking on the topmost button in the snap settings bar on the right.

If you need snapping, open the preferences with Edit > Preferences > Behavior > Snapping and check the option to only snap to the node closest to the mouse pointer. Also disable all snap targets in the snap settings bar that you do not need.

Then, try to work on simplifying the file.

jenniferh (jenniferh) said : #2

Tanks for your suggestions. Turning snapping of works, but it is still awfully slow, up to the point where I have to wait minutes until it comes back to life. The problem is that I have a plot and I cannot just remove datapoints. Is there another way to simplify such a file? (Sorry
Is this slowing down due to internals or is there a possibility to just increase Memory somewhere so that it will be able to handle such files?

Right now I just use the png. A possibility I found was to just link to the png and then replace the link with the svg before exporting it to pdf. The problem I encounter is that as soon as I change it to the svg (in the XML editor) I get a linked image not found error (probably linked to this: https://bugs.launchpad.net/inkscape/+bug/168244)

Is there a method to import the svg at exactly the same place where the pngs are with the same formatting? That at least would give me the opportunity to import the svg as a last step without having to move them (which is problematic even without snapping)

Hachmann (marenhachmann) said : #3

Maybe this will help:

https://forum.inkscapecommunity.com/index.php?action=articles;sa=view;article=35

If you need further help, please share the actual file (via link to file).

Linking SVG files works in the development version, but there is no user interface for it in the released version. Also, it looks bad when exported, if the 'make bitmap copy' resolution is low. That can be set more easily in the development version.

I'd try out the tricks in the above article first.

Can you help with this problem?

Provide an answer of your own, or ask jenniferh for more information if necessary.

To post a message you must log in.