help with PNG export

Asked by Brenda Lung on 2019-02-12

After creating a simple shape, I'll export the selection as a PNG. When that file is imported in my CAD software, the colors are inverted and the background is black. I'm expecting the colors to be what I see on the Inkscape screen and a transparent background (which is typically what a png is). If I invert the colors in Inkscape (ver 0.92.2), it's better. But, if the shape is a circle, the export creates a box around that shape (circle or teardrop). The box becomes a path once imported into my CAD. Are there settings I need to change in order for the exported PNG to behave with a transparent background and only the exterior lines of my shape (and not the added box). (Imagine the "handles" around the shape - that's the box the final export resembles)

Question information

Language:
English Edit question
Status:
Expired
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2019-02-13
Last reply:
2019-03-01
Hachmann (marenhachmann) said : #1

Looks like you CAD software doesn't support PNG properly...

Why don't you import the actual SVG instead? PNG files are inherently rectangular, nothing can be done about that.

Brenda Lung (ladybug222) said : #2

Thanks for your response......

My CAD doesn't support the .svg files that I can export from Inkscape. It doesn't like many of the files that come out of Inkscape, but a PNG will work.

What has happened that's quirky....

If I download a PNG off the internet, that will import (in the CAD-RDWorks) just as expected and with a transparent background with no added "box" around the image.

If I create a screenshot of my graphic (on my mac) and export as a PNG and then import into CAD (RDWorks for my laser cutter), then it behaves as expected.

When I create an image from Inkscape on my mac, the software doesn't allow me to save or export. But I can create a screenshot and export as PNG. Not as crisp this way.

When I create an image from Inkscape on my pc and export as PNG, it gives me a black background and the added "box" around the image.

Just wondering if anyone else has experienced this and what has been done to correct it. Also, is there a setting to change as far as the PNG properties go or a box to uncheck before exporting? Or, any other suggestions.

Thankfully, my laser cutter is forgiving with its output. But, I engraved text recently and would like the edges to be crisper. The screenshot can get choppy on the edges once I go through all those steps. I know that's not the proper way, but trying to make things work with the roadblocks I'm currently encountering. I feel if I can just get the PNG to properly export out of the PC Inkscape, I can get crisper output on the laser engraving.

Thanks for taking the time to help.
Brenda

Hachmann (marenhachmann) said : #3

I'd still recommend using SVG rather than PNG (aside from this issue, that was supposed to be solved long ago).

I understand it that your CAD program can read SVG in principle, but only chokes on those from Inkscape?

Have you tried exporting to:

- dxf
- plain SVG

instead of 'Inkscape SVG'?

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Open' state without activity for the last 15 days.