0.92.4 unexpectedly preserves skew on stroke

Asked by Discrete Games on 2019-02-06

In Inkscape 0.92.3 when I would draw a shape with a stroke and skew it, the stroke would realign itself to the skewed shape, remaining the same thickness everywhere.

Now in 0.92.4 when skewing a shape with a stroke the stroke stays skewed, so it is thicker in some places and thinner in others, depending on the amount and direction skewed.

(Both of these behaviors have their uses but you could always group an object then skew it to get the current behavior.)

Is this change intentional? Or is there a setting I'm missing that can put things back to how they were in 0.92.3?

Question information

English Edit question
Inkscape Edit question
No assignee Edit question
Last query:
Last reply:
Hachmann (marenhachmann) said : #1

There is a setting for it in the preferences.


Discrete Games (discretegames) said : #2

I tried that. It doesn't work in 0.92.4. Though it did work in 0.92.3.

Hachmann (marenhachmann) said : #3

Strange - this doesn't happen for me.

What's your OS, installation source, and version info from Help > About?

Can you share a link to a file that is affected?

Hachmann (marenhachmann) said : #4

And a link to a copy of your preferences.xml file?

Discrete Games (discretegames) said : #5

My installation source was the Windows 64 bit exe installer, upgrading from 0.92.3 (it uninstalled that first) on Windows 10 Home 64 bit.

Though to avoid the problem I reinstalled 0.92.3 and don't want to bother with reinstalling 0.92.4 again (it won't let me install multiple versions at once) so I don't know if I can provide the right files. But here is my 0.92.3 preferences.xml: https://pastebin.com/raw/t6sfjsmD and a sample.svg with some sample shapes: https://pastebin.com/raw/zXePjhzc

Maybe it's important that my shapes are BSpline paths rather than regular Bezier paths? I didn't check other path types.

Hachmann (marenhachmann) said : #6

Confirmed, it's different between 0.92.3 and 0.92.4 for Paths with a BSpline Path Effect.

As a workaround, you can do:

Path > Object to Path (this removes the LPE while keeping the shape)
and then use the arrow keys to move the path up once and down again. This triggers a rewrite of the path.

Please also report the problem at https://gitlab.com/inkscape/inbox/issues/ (our new issue tracker), so it can be fixed for future versions (this also happens in the development version for Inkscape 1.0).

Discrete Games (discretegames) said : #7

Already reported on gitlab: https://gitlab.com/inkscape/inbox/issues/72

Thanks for the help!

Hachmann (marenhachmann) said : #8

Thanks for the report :)

Can you help with this problem?

Provide an answer of your own, or ask Discrete Games for more information if necessary.

To post a message you must log in.