installed fonts don't appear on fonts menu

Asked by Marianna Ark on 2018-12-26

Downloaded fonts do not appear on the drop-down fonts menu of the toolbar nor of the drop-down menu of the sidebar.
I am using Inkscape 0.92.3 (2405546, 2018-03-11) on Windows 10, 64 bit, pro. The fonts come from dafont.com, some ttf and some otf
So far I've tried:
-installing older versions of Inkscape (both other 0.92 versions and older than that)
-various methods of installing fonts (drop in windows FONTS folder, copy + paste, right click on the font file and selecting 'install')
-deleting the font cache file of windows
-installing fonts from other sources, including windows store

The new fonts appear on Microsoft Office, Libre office and the pixlr online editor. I installed fonts on another computer that used windows xp and they did appear on Inkscape, and I watched youtube videos of people installing fonts from the same source and they appeared just fine on Inkscape, so I am assuming that I haven't made any mistakes on the font installing process.

Any suggestions?

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Marianna Ark
Solved:
2018-12-26
Last query:
2018-12-26
Last reply:
Marianna Ark (marianna.ark) said : #1

You have to install fonts this way: right click on font file and instead of 'install' select 'install for all users', even if the only user is you. I've seen people install fonts with the simple copy + paste method and it worked just fine so I'm assuming that there's still some kind of problem in the way windows communicates with Inkscape and what resources are available to it - so I'm leaving this question here instead of deleting it.

Hachmann (marenhachmann) said : #2

The devs aren't going to work on anything listed here. If you suspect there is a bug in how Inkscape detects fonts on Windows, please open a bug report here: https://bugs.launchpad.net/inkscape