Why is inkscape snapping to grid *lines*?

Asked by Matthew Woehlke on 2018-11-26

While trying to edit a certain document, I noticed that inkscape is snapping to grid *lines*, which is making it annoyingly difficult to do what I want, which is only snap to grid *intersections*. I can't find any option to control this, and even more bizarrely, if I create a new document, I only get snapping to intersections, as desired.

What is going on here and how do I fix it?

Question information

English Edit question
Inkscape Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
TylerDurden (8thrule) said : #1

I'm guessing the grid is higher resolution. I'd try zooming in a lot to see if there are more lines.

Grids can be created/adjusted in the document properties


Matthew Woehlke (mw-triad) said : #2

That's not it. Besides I was zoomed in enough to see all grid lines, the snap tool tip clearly said "snapping to grid *line*", not "snapping to grid *intersection*" as it normally would when this behavior isn't occurring. (Besides, inkscape doesn't snap to grid stuff that isn't being drawn, anyway.)

TylerDurden (8thrule) said : #3

Well, you could upload an example file and post a link to it for examination.

Matthew Woehlke (mw-triad) said : #4

File experiencing the problem:

Screen shot of the problem:

...although even with the same file, I don't seem to have the problem on other computers. Could it have something to do with display scaling? (The computer having the problem is running at 2x display scaling. All of my machines are running Fedora.)

Best TylerDurden (8thrule) said : #5

Thanks for the files and pic.

I am able to duplicate the behavior by setting the snaps in the Document Properties panel to snap to grids only when within 10px (same as in the example file).


Setting the snap-to-grids to "Always" forces the snap to the grid intersections.

I'd check a new document on the the Fedora machines to see what the setting is for the default.svg. It may need changing/saving with your preferred setting,

Please chime back and let us know you get along.


Matthew Woehlke (mw-triad) said : #6

That particular SVG originated several years ago (maybe 6-7); it's possible the defaults have changed since then. I'll have to check what happens on my other machine...

At any rate, the answer to the original question appears to be "because that's what it does when snap to grids is set to 'only within X'".

Now... I suppose the next question is, is it *supposed* to do that?

Matthew Woehlke (mw-triad) said : #7

Thanks TylerDurden, that solved my question.

Matthew Woehlke (mw-triad) said : #8

Okay, I *do* see the same behavior on my other computer. I think, because it is lower resolution, I was just not ever zoomed in enough to be far enough from grid intersections to notice. (IOW, it is affected by display scaling because the snap distance is in physical pixels, not logical units.)

TylerDurden (8thrule) said : #9

Yeah, I played around with the settings a bit just now...

I'll file a bug/wishlist report to suggest a label change from "Always snap" to "Only snap to grid intersections". It seems that's a more accurate description of the behavior.


TylerDurden (8thrule) said : #10

Created bug report (wishlist):

Please visit the report and click the "This bug affects me" button.