Inkscape is all grey except for the color palette. How do I fix this?

Asked by Tim Nason on 2018-09-11

I've just installed Inkscape on Linux Mint but everything is grey except the color palette

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Hachmann
Solved:
2018-09-22
Last query:
2018-09-22
Last reply:
2018-09-21
Hachmann (marenhachmann) said : #1

What exactly is grey? The icons? The text? The page background? The colors in your SVG file?... Please elaborate.

Also let us know:

- your Linux Mint version
- your Inkscape version
- how you installed Inkscape

Tim Nason (timster) said : #2

What exactly is grey? The icons? The text? The page background? The colors in your SVG file?... Please elaborate.
Everything on the application's screen is a shade of grey except for the color palette and the green in the close button

Also let us know:

- your Linux Mint version Linux Mint 19 Cinnamon - cinnamon version 3.8.8
- your Inkscape version Inkscape version 0.92
- how you installed Inkscape software manager

Hachmann (marenhachmann) said : #3

So you have a problem with the selected theme? Or are the icons missing?

Please share a screenshot, it's hard to tell what the issue is (use imgur.com or another image hoster - email attachments don't work here).

On the commandline, please do

  inkscape --version

and also

  flatpak list | grep inkscape

and

  snap list | grep inkscape

Then we can see which Inkscape exactly you have installed.

Hachmann (marenhachmann) said : #4

I forgot to add:

... and post the output of the commands here.

Tim Nason (timster) said : #5

I haven't selected any theme and as far as I can tell there are no icons missing.
I'm not familiar with image hosters so just imaging everything disabled except the color palette. Even though all the icons are greyed out, they seem to work.

inkscape --version
Inkscape 0.92.3 (2405546, 2018-03-11)

flatpak list | grep inkscape produced NO results

snap list | grep inkscape
No snaps are installed yet. Try 'snap install hello-world'.

Hachmann (marenhachmann) said : #6

I think we really need a screenshot here, Tim.

If I were to guess, I'd say, it looks like it could be a theme issue (your package maintainer fancied the gray icon set and thought everyone should use it). This can be changed.

Navigate to /usr/share/inkscape/icons.

Copy the file with the Tango icons (tango.svg) to /home/<your_username>/.config/inkscape/icons/icons.svg

Tim Nason (timster) said : #7

Is seems to be more than just and issue with icons. I tried the tutorial and tutorial-basic.svg looks ok and has color but it says to create a rectangle and that is should be blue but all I get is the outline with and x in the middle squares at top left and bottom right and a cirlce at the top right. When I hover over the corner rectangles, they turn red and the circle turns blue.

Hachmann (marenhachmann) said : #8

Please make a video of what you're seeing, Tim.

peek is a software for screen recording that works great on Linux Mint:
https://github.com/phw/peek

After saving the video, please upload it to:
https://framadrop.org/

Hachmann (marenhachmann) said : #9

(and share the link here, of course)

Tim Nason (timster) said : #10

Here is the link provided by framadrop:
https://framadrop.org/r/1xcdzhF2mC#sCUSZM+U7OFjjL5/5v+yCyp6Wnrj7hsBBu+cGtkyAbA=

I did try copying the tango icon file as suggested and restarted inkscape but it seems to have no effect.

Hachmann (marenhachmann) said : #11

Mmh, I'm not sure about the weird extra black thing that appears when you're drawing, but your icons are just not the normal ones, and the rectangle you're drawing has zero opacity.

Change the opacity in the bottom left corner, with the rectangle still selected after drawing.

I don't know why the icons don't work. Did you rename the file (from tango.svg to icons.svg)?

Tim Nason (timster) said : #12

Yes, the file was actually called tango_icons.svg and it said it was an old version when I tried to open it but I saved and renamed it anyway.

Hachmann (marenhachmann) said : #13

I'll try to reproduce this on a virtual machine, then I'll be able to tell you exactly what to do. Which version of Linux Mint did you install?

Cinnamon? Mate? Xfce? Linux Mint 19?

Tim Nason (timster) said : #14

Linux Mint 19 Cinnamon - cinnamon version 3.8.8

Best Hachmann (marenhachmann) said : #15

Okay, so the reason is that the Linux Mint peeps messed with your ability to use custom icons for Inkscape by putting icons for Inkscape into their own Mint-Y icon set (booh!).

If you want to get the normal icons back, you can either:
- delete all Inkscape icons from the Mint-Y icon set (not recommended, needs sudo)
- switch desktop theme to Adwaita (or something else that makes Inkscape look right for you)

Hachmann (marenhachmann) said : #16

Sorry, to be more precise:

swith desktop ICON theme to Adwaita. You don't need to switch the theme itself.

In Settings > Themes > Icon theme in the Linux Mint menu.

Tim Nason (timster) said : #17

VoilĂ . I now have icons that look usable. Thanks a million.

Tim Nason (timster) said : #18

Thanks Hachmann, that solved my question.