Inkscape default menu/dialog font VERY large

Asked by cancerlad

computer : MacBook Pro 5,1
OS : Mac OS X 10.5.6
kernel : Darwin 9.6.0
inkscape version : 0.46
X11 version : 2.3.2

I recently had to rebuild my mac from the ground up. I re-installed the OS and all the programs I had on it before. Every other program seems fine, but for some reason all the text in Inkscape seem very, very large - to the point of distraction. For example, the menu font seems to be either 32 or 36 point. The dialog fonts also appear to be larger than they should, but not nearly so outrageous.

Is there anyway that I could set the fonts to a smaller size? All the other X11 application's fonts seem normal.

Question information

Language:
English Edit question
Status:
Answered
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
su_v (suv-lp) said :
#1

This problem is related to the interaction of X11 on Mac OS X and gtk+ settings.

X11 2.3.2 has changed with regard to screen dpi (from default 72(?) to 96dpi or user-defined: on my MBP 15,4" I have set it to 110dpi).

Some of the older gtk-settings for e.g. Inkscape and GIMP compensated the inadequate dpi-setting and the resulting tiny UI fonts with larger point sizes.

I found the thread on the X11-user mailing list <http://lists.apple.com/archives/x11-users/2009/Jan/msg00014.html> helpful. The last posting <http://lists.apple.com/archives/x11-users/2009/Jan/msg00091.html> lists the files you can use to adjust the gtk-font-settings for Inkscape (if you are comfortable using terminal.app and fiddling inside the application folder... ;-)

hth, ~suv

Revision history for this message
Zearin (zearin) said :
#2

I just got the huge font size issue after upgrading my X11 to the latest version.

(You can find the latest X11.app here: http://xquartz.macosforge.org/trac/wiki).

Thanks to the thread posted above, I modified some of the advice and came up with the following. Hoping this is faster for anyone else with this problem than all the searching and reading I just did. ;-)

1. Open Terminal.app
2. type in the following and hit enter:

defaults write org.x.X11 dpi -int 72

DONE. =)

(I'm on a white MacBook, btw, in case that matters.)

Revision history for this message
su_v (suv-lp) said :
#3

yep, that works too ;-) I prefer the other solution because I'd rather have X11 use a screen resolution that corresponds to the physical resolution of my LCD screen (MBP 15.4 has approx. 110 ppi) and adjust the GTK+ configuration than use a 'arbitrary' screen resolution adapted to old gtkrc settingsā€¦

But thanks for your tip! ~suv

BTW - Inkscape 0.46+devel and 0.47pre already ship with new GTK theme settings that take the recent changes in X11's default screen resolution into account. So, when you upgrade - you might get tiny GUI fonts unless you change back the dpi to 96.

more info in this bug report: <https://bugs.launchpad.net/bugs/263932> beginning with comment 7

Can you help with this problem?

Provide an answer of your own, or ask cancerlad for more information if necessary.

To post a message you must log in.