Svg created with Visio: Linux renders pattern, windows does not. Bug?

Asked by Maximilian Hartert on 2018-07-31

Hello,

I have a svg. That contains a small rectangle which is filled with a pattern. The pattern consists of red lines, which run diagonally from bottom left to top left. I created that file in Visio 2016 and saved it as an svg.
When I open the svg with the Linux version of Inkscape, everything looks fine.
While the Windows version shows an empty rectangle. It does not render/display the pattern.
I use version 0.92.3 on both systems.
Is this a bug? Perhaps something is misconfigured on my Windows machine.

Here is the content of the svg file: https://pastebin.com/T679WL6H

This is how the exported png looks on Linux (expected output): https://imgur.com/1cGxvd3
Here is the png I have created on windows: https://imgur.com/YJGFjaD

How can I make the pattern visible on the windows version? Or why does Inkscape behave differently between operating systems?

My Linux is Ubuntu 16.04.4 LTS, actually it's the Linux subsystem on Windows to be more specific. I run Inkscape with the help of my installed xserver (VcXsrv).
Windows is therefore Win 10 (enterprise edition).

Should this be a bug, I will make a report. I have not found a bug ticket or question regarding my problem.

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Maximilian Hartert
Solved:
2018-08-02
Last query:
2018-08-02
Last reply:
2018-08-01
Hachmann (marenhachmann) said : #1

Can you try it with identical preferences files on both systems? (i.e. rename both, e.g. 'preferences.xml.windows' on Win, and 'preferences.xml.Linux' on Ubuntu, and exchange copies of them which you name back to preferences.xml)?

(Location of preferences file is indicated in Edit > Preferences > System)

Could be a problem with different settings for 'move pattern when objects are moved' button, perhaps.

Let us know what happens, please.

(Inkscape runs on the subsystem? I'm surprised...)

Hi,

I have just exchanged my configs. That did not change my results.
The Linux version is doing fine again.
While Windows, with the config from Linux, still displays an empty rectangle.

I have not configured anything yet. But I see that the two configs vary a little in it's content.

Hachmann (marenhachmann) said : #3

Thank you for trying that out, Maximilian.

Would it be possible that you share a link to a Visio-created file that exhibits the problem? I can test on a Win 10 VM and on Linux Mint.

(a reason for configs varying could be that you've upgraded one version, and have a fresh install for the other. Could that be the case?)

Sure, here is the svg that I have created with visio including the original visio file: https://drive.google.com/open?id=1R5I485-TMtMKGkhnY1vHaKIo1JQ8JNkI

Yeah, on Linux I had the version from the Ubuntu repository first. Later I switched to the official Inkscape ppa for the current version.

Hachmann (marenhachmann) said : #5

Mmmh. Works for me on Win 10... :-/ I've opened the SVG file, and get a striped rectangle. The stripes consist of an 8x8px bitmap, so it doesn't look good, but it *is* striped (using a vector pattern could improve the look a lot, but this might just be an example).

However, when I open the original Visio file with Inkscape, I get an empty rectangle, both on Win and Linux. That's probably not what you did? Accidentally, maybe?

Which download file did you use for installing the Windows version of Inkscape? (last idea...)

Of course I have openend the svg file.

I got it working now. It was the version I was using...

Until recently I was using the binary version, that I just had to unzip. Now I renamed the folder with the old config, just to have an backup. Following an proper install. That somehow fixed it. For the install I have used the exe install.

So it is either is some setting or the zipped version for windows?
Even with the new setting folder, that the installed version has created, the unzipped binary is still failing.

Anyways, I got it solved now. Thank you for your help!

Hachmann (marenhachmann) said : #7

Mmh, there shouldn't be a difference between the zip install and the normal one.

Can you double-check which preferences file the zip install is using?
It would be good to know the cause for this behavior.

See Edit > Preferences > System > User config.

If that is really the file you have exchanged previously, and it also doesn't work when you just rename the file, so Inkscape creates a new one, please make this a bug report.

I have just reactivated the config folder that the zipped version originally created.
The installed Inkscape is still working fine.
So it must be the zipped version. Even with a fresh config, it is still failing for me.

I will make a bug report later.

Hachmann (marenhachmann) said : #9

Thank you, Maximilian. That's going to help us improve Inkscape for everyone!

I don't think a bug report is necessary anymore. It seems to be exactly that version I downloaded, which caused trouble. Newly downloaded zipped versions work fine...

I redownloaded the zipped 64 and even 32 bit version this time. I let both versions create a config on first start. They render the pattern fine.

So either my original download is somewhat broken, or it is the release which was available back then. I always use the official download page of inkscape.org.

Hachmann (marenhachmann) said : #11

Okay, thank you for this really thorough testing, Maximilian!

I'm glad to hear that the problem is solved with the most recent version :)

Have a great weekend!

No problem, since it affected me somewhat I wanted to have it properly resolved.

You have a great weekend too!

Hachmann (marenhachmann) said : #13

Danke! :)