I can't insert word accents using the shortcut in Mac/OS

Asked by Maria Ostrower on 2018-07-22

My language is Portuguese and whenever I try to insert certain accents using the keyboard on a Macbook, the inkscape simply doesn't recognise it. Instead, the Inkscape interprets the shortcurts ( such as: option+n) as commands to other things and some windows open.
How can I fix this?

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Maria Ostrower
Solved:
2018-07-22
Last query:
2018-07-22
Last reply:
2018-07-22
Hachmann (marenhachmann) said : #1

Does this part of the FAQ help?

https://inkscape.org/pt-br/aprender/faq/?edit_off=true#questoes-especificas-de-mac-os-x (It's in Brazilian, but you may still prefer that to English)

Maria Ostrower (cinnamongirl) said : #2

Thanks Hachmann but that doesn't answer my question. In fact I am from Brazil and here we speak Portuguese, although some people think we speak Brazilian... It's a Brazilian Portuguese, sure, but officially the language is Portuguese. Thanks a lot!

Hachmann (marenhachmann) said : #3

Just got your reply in my inbox, even though it seems it has been deleted from here...

I know about the Brazilian (Portuguese), I organize the website translations :)

It's unfortunate that the FAQ items didn't apply to your issue.
Would it be possible to use another key for the windows management commands? I'm on Linux, and there that key is 'Alt', but it can be changed. Maybe macOS has the ability to change that, too?

Else you may need to use copy-paste, or use the unicode entry method for Inkscape (Ctrl+U, then type the unicode number, then hit enter, see https://inkscape.org/en/doc/keys092.html#idm3378 for help with this).

Maria Ostrower (cinnamongirl) said : #4

Hi there,
I terribly sorry about my presumption! Also, I managed to insert the accents now! The "emulate three..." was already unchecked so I unchecked all the categories under INPUT and it worked!

Thank again for all your help!

Hachmann (marenhachmann) said : #5

No worries :) And glad that you could make it work!