Screen tearing on high zoomed objects, any fix?

Asked by Maciej on 2018-07-04

comp specs: windows 7, i5-4460, radeon r9 270, 16gb ram, screen 1360x768, program installed on ssd, latest version.

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Maciej
Solved:
2018-07-09
Last query:
2018-07-09
Last reply:
2018-07-05
Hachmann (marenhachmann) said : #1

What kind of objects are in your file? Can you share a link?
Are you using filters? (these include: blend modes, filters, blur)

Maciej (maciej1022) said : #2

im trying on some pictures from web ~500x500px 50kb and calligraphy tool or star from template. any filters just added photo and zoomed on it.

Hachmann (marenhachmann) said : #3

Okay, please share a link to a file, if possible.

Also tell us if you've ever had the objects dialog open while using Inkscape. It has a very severe impact on performance.

Hachmann (marenhachmann) said : #5

Yes, that's definitely strange behaviour. It shouldn't be happening with just a simple photo. It doesn't do that for me, and my specs are similar (only I'm on Linux).

Is there a lot of other software running in parallel?
Do you have the objects dialog open (or opened it) in Inkscape?
Can you share an SVG file that has the issue for you, please? (imgh.us and framadrop.org support SVGs, for example)

Maciej (maciej1022) said : #7

solution is change rendering cache size to 1 and rendering tile multiplier to 64

Hachmann (marenhachmann) said : #8

As far as I know, that setting only has a larger effect when there are filters in the drawing... There weren't any, you said? That's good to know.