inkscape problem

Asked by hussainsab m gurgunni on 2018-04-28

Hi My name is Rick
I am trying to run MI Servo controller extension and when I setup to just draw a square it gives me this error.

Traceback (most recent call last):
  File "servo.py", line 3172, in <module>
    e.affect()
  File "inkex.py", line 283, in affect
    self.effect()
  File "servo.py", line 3156, in effect
    self.orientation( self.layers[min(0,len(self.layers)-1)] )
  File "servo.py", line 3085, in orientation
    doc_height = inkex.unittouu(self.document.getroot().get('height'))
AttributeError: 'module' object has no attribute 'unittouu'

Being very new at this I have tried several times and get the same error every time. I have setup a notebook and a desktop computer thinking that it is a computer problem? Installed the extensions on both systems and get the same error.

Question information

Language:
English Edit question
Status:
Answered
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2018-04-28
Last reply:
2018-04-28
Hachmann (marenhachmann) said : #1

The extension is too old for working with Inkscape 0.92.(x).
Either ask its author to update it, update it yourself, or use Inkscape 0.48.5 .

More info here:
http://wiki.inkscape.org/wiki/index.php/Release_notes/0.91#Units:_Breaking_change

Can you help with this problem?

Provide an answer of your own, or ask hussainsab m gurgunni for more information if necessary.

To post a message you must log in.