Missing Scrollbar in Linux

Asked by Queenie Li on 2018-02-12

This is another strange oddity that only happens to me with the Linux version of Inkscape (but Windows version behaves as expected). The very bottom scrollbar under the palette has gone missing. When i first started using it, there was a scrollbar there that allowed me to scroll through the colors so I can actually see them all. Now it's just a blank space. If I click in that blank space, it will jump along the palette line, but that's very hard to use because I can't really control where I'm going very well.

To be clear, I'm not missing ANY other scroll bars. The document ones are there and I fully understand how to enable/disable those. It's only the bar for scrolling through colors that's gone.

To add to the mystery, if I click the arrow at the end and enable Wrap then disable Wrap, the scrollbar comes back... until I close Inkscape and then when I open it again, it's gone again... so I basically have to do this trick every time I want to use the palette selector. It's a minor annoyance but still an annoyance. I'm not sure why the bar isn't there by default any longer. My Windows version always has it there.

If it helps, I'm running Linux Mint 18 and Inkscape version 0.91 r13725

Question information

Language:
English Edit question
Status:
Open
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2018-02-15
Last reply:
Hachmann (marenhachmann) said : #1

Never had that issue myself, but can you try the most recent version from the ppa?
(and let us know which desktop environment you're using)

PPA link: https://launchpad.net/~inkscape.dev/+archive/ubuntu/stable

Queenie Li (crazyli825) said : #2

Huh... didn't expect the Package Manager to not be giving me updated versions on its own. I guess Mint 18's PPAs tend to be very out of date, huh?

Anyway... updating didn't bring the scrollbar back. In fact, all it did was make some ugly backgrounds on everything, so I think that made matters worse xP

I'm using Cinnamon for desktop environment.

Hachmann (marenhachmann) said : #3

Linux Mint 18 is based on Ubuntu 16.04. So you will have software versions from 2015/2016, with security fixes and some small updates (ppa = personal package archive - usually for just one or two programs, repository = official package source for the whole distro). This is the whole concept of a distribution with fixed release cycles.

If you want newer software, you need to either use another distro (e.g. something that has 'rolling releases'), or use ppas, flatpak, appimage, snap, ... docker for the specific application you want to use.

Can you make a short screencast that demonstrates the issue?
You could use peek (https://github.com/phw/peek) for it, which is a very cool screen recording software.

Which desktop theme are you using? Anything that is not default?

Can you copy-paste the output you get when you start Inkscape from the command line and play with the palette?

In the bug report section, I couldn't find your issue, so we might need to collect some data.

Can you scroll the palette with (maybe Shift+)mouse wheel?

Queenie Li (crazyli825) said : #4

I switched to default desktop theme for the purpose of this recording to show it doesn't change the issue.

When launching Inkscape through the terminal, I see no output.

Shift+mouse wheel does indeed scroll the palette though so that's at least handy to know.

I made a brief recording that hopefully makes sense. Every new launch is like this. No scrollbar or even clickable arrows to scroll unless I do the Wrap trick and then it on persists until I close Inkscape. Also you can see the ugly colors that the latest version has given me. I feel like I should downgrade to the one I had because this newest one is definitely worse.

https://drive.google.com/open?id=1w0iDjWWUDRb0I_udhtThsd14MBW03ggn

Hachmann (marenhachmann) said : #5

Mmh. I just tried it out.
VirtualBox, Linux Mint 18.3 Cinnamon edition, Inkscape 0.92.2 from ppa. It does not look like yours does, but just gives me a normal Inkscape.

I suspect some weird configuration issue...
Did you do the renaming of the preferences file (for the scroll bar, it could perhaps work...)?

Do you remember changing anything 'special' in your desktop, e.g. installing something that has to do with Cinnamon or gtk from some ppa, running some developer version of a weird software, making some unusual settings... ? I have no idea where to find a starting point for figuring this out, to be honest.

Queenie Li (crazyli825) said : #6

1. Tried renaming Preferences file - no change

2. No changes to desktop that I'm aware of... don't recall installing anything for Cinnamon or GTK.

Despite this, the issue has to be rooted in Cinnamon somehow. I switched to MATE and don't have any of those problems. No ugly black BGs, scrollbar is present... seems fine. Just on Cinnamon is it bugged. Problem is that even trying to re-install Cinnamon doesn't resolve the issue so I dunno what the heck the issue is. I really prefer the Cinnamon desktop though.

Hachmann (marenhachmann) said : #7

Yeah, sorry I can't help with this.

You could try to collect info by contacting a larger range of people via inkscape-devel or inkscape-user mailing lists and whatever the Cinnamon devs use for communication. Maybe one of them has encountered this and knows why it's happening...

Can you help with this problem?

Provide an answer of your own, or ask Queenie Li for more information if necessary.

To post a message you must log in.