Unusual Default Zoom Percentage

Asked by Queenie Li on 2018-02-12

I'm having some weird issues with the Linux version of Inkscape where documents open at very weird/random zoom levels. If I open a new document, it's always 115% zoom. If I open an existing document, it could be anything. The most common is 329%, but sometimes it's over 1000%. It tends to be super highly zoomed in when I have filters applied which is the worst time to do that because it lags my computer tremendously to process those effects at such a high zoom level. This only happens when using the program under Linux. Windows ALWAYS opens at 100% zoom no matter new or old file... even opening the exact same files that open as 329% under Linux.

Now I've heard people say that documents open at the zoom they were saved at... but I assure you, I NEVER work at such an arbitrary zoom as 329%. I only ever use 50, 100, 200, 400, and rarely 800%... and I pretty much always am at 100% when saving. Again, the same file opens at 100% fine in Windows. Is this some sort of bug or did my Linux version get some kinda weird setting that screwed it up somehow?

If it helps, I run Linux Mint 18. Inkscape version is 0.91 r13725

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Queenie Li
Solved:
2018-02-14
Last query:
2018-02-14
Last reply:
2018-02-13
Hachmann (marenhachmann) said : #1

Linux Mint 18.3 myself, and I never had that issue (and I usually use the most convenient zoom, not any fixed level - Ctrl+Scroll wheel).

Can you: update to the current version, then re-test, then, if it still happens, share a file that exhibits the issue with a description of what you get when you open it?

(for sharing files, please use an online file hosting service, email attachments do not work)

Queenie Li (crazyli825) said : #2

No, updating didn't resolve the issue (just made Inkscape look ugly). I can try uploading a file somewhere but I'm very doubtful it'll help anything if the same file opens at 1x zoom under my Windows Inkscape. Chances are, it'll open fine for another user if they don't experience this issue themselves.

https://drive.google.com/open?id=1Qzt1MpJkmKsmn31uGYagfWPFnGsQbPYe (hopefully that works)

When I open the file (through the right click context menu "Open with Inkscape"), it starts out zoomed in to 646%. Also just opening a brand new Inkscape window by launching the program on its own (with nothing else open) starts out at 113%... so it doesn't even have anything to do with the file. It just by default opens at weird percentages on its own.

Hachmann (marenhachmann) said : #3

So, the file says it should open at 200%.

The default document should open at 35% (you didn't change it, right?).

So all files open 3,22 times larger than they should - it's not random.

Can you check in your Inkscape preferences at Edit > Preferences > Interface > Windows : Miscellaneous, if there is a check for the zoom-when-resized option?

And a general idea: Can you rename your preferences file (find it at ~/.config/inkscape/preferences.xml), and start Inkscape again?

Do you have some unusual monitor setup, maybe?

Aaand lastly, can you check with another desktop environment, if the above ideas don't work - if you have one installed already, that is. Many people have KDE and/or Gnome installed, because they are using applications that need their libraries.

Queenie Li (crazyli825) said : #4

It was the Zoom-when-resized. Thanks so much!

So odd that that was checked when I never even knew about that option so I certainly didn't set it. And it's not checked by default in Windows so why would it be here? Oh well... I don't care. At least that problem is resolved.

Hachmann (marenhachmann) said : #5

Yay :)