Problem with General Display Units Property not saving

Asked by Charles Cecil on 2018-02-05

I just downloaded and installed the newest version of Inkscape 0.92. When opening files created in the previous version 0.91, the General Display Units opens as pixels, even though in the previous version the properties were set as inches. Now the Custom Size property is set as inches, but not the General Display, When I change the General Display to inches, the rulers do not change and remain set as pixels. It doesn't matter if I save the file with inches selected, when I close the program and re-open the file the General Display units always shows pixels. I need to point out that the grid display appears to be in one inch increments, so it looks like it's just the General Display and rulers.

Also this doesn't happen if I create a new document. From what I see it is only when I open previous projects. What do I need to do to get the Inkscape Document Properties to accept the General Display document conversion to inches?

For your information I am using an Intel computer with the Windows 7 SP1 operating system.
Thank you.

Question information

Language:
English Edit question
Status:
Open
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2018-02-07
Last reply:
2018-02-07
Hachmann (marenhachmann) said : #1

Can you share the file, please, and make an easy-to-follow step-by-step description? That will make it faster to help you.

You can use any file hoster, e.g. https://framadrop.org or google drive etc. to share your file. Post a link in your next message.

Charles Cecil (clcecil) said : #2

https://drive.google.com/file/d/1w_MGxcAaRS7EGZhk17L5WOSkD8JZzUbY/view?usp=sharing

After upgrading Inkscape .092.2 from the previous version Inkscape
.092.1, I opened a project I had started on the previous version (see
link).When it opened, it displayed a dialog box like the one inserted
below. This example is from another file with the same problem.

I selected the first option as in the illustration and clicked okay.When
the file opened the rulers were set for pixels, so I opened the Document
Properties box.Under General, the Display units were set as pixels. All
other settings in the dialog box were set to inches. I changed the
Display units to inches. However the rulers did not update to inches.I
saved the file and closed and re-opened it. When I opened the Document
Properties box, the General/Display units was set to pixels again. I
performed different variations of saving, closing, and exiting the
program, but nothing worked. As a work around, I finally created a new
file, set the document for inches, and imported the objects from the
affected file. I don't want to open any of my older projects until I can
get a handle on what happened to this file and how it can be properly
corrected.
I appreciate you taking the time and attention for this problem.
Thank you.

Chuck Cecil

------ Original Message ------
From: "Hachmann" <email address hidden>
To: <email address hidden>
Sent: 2/6/2018 7:02:24 AM
Subject: Re: [Question #664114]: Problem with General Display Units
Property not saving

>Your question #664114 on Inkscape changed:
>https://answers.launchpad.net/inkscape/+question/664114
>
> Status: Open => Needs information
>
>Hachmann requested more information:
>Can you share the file, please, and make an easy-to-follow step-by-step
>description? That will make it faster to help you.
>
>You can use any file hoster, e.g. https://framadrop.org or google drive
>etc. to share your file. Post a link in your next message.
>
>--
>To answer this request for more information, you can either reply to
>this email or enter your reply at the following page:
>https://answers.launchpad.net/inkscape/+question/664114
>
>You received this question notification because you asked the question.

Hachmann (marenhachmann) said : #3

Hi,

so this corresponds to https://bugs.launchpad.net/inkscape/+bug/1671691

Until the bug is resolved, you can use this workaround:

- Open File > Document properties
- Open the 'viewbox' section in the first tab
- Trigger the creation of a viewbox by adding 1 (or any other number) to one of the values, hit Enter
- Fix it to its correct value by subtracting 1 (or any other number) from the value you modified previously, hit Enter.
- Change the unit in the top right corner ('Display units')
- Save
- Close and open document

Hachmann (marenhachmann) said : #4

Can you please append the image that shows which option you selected to the linked bug report?

Attachments do not work in the 'answers' section, but they do in bug reports. I do not know which option you selected.

Charles Cecil (clcecil) said : #5

Per your request, I added the dialog box attachment to the bug report.
At this time I have not tried the resolution you sent to me. I will send
you an update after my attempt.
Thank you.

------ Original Message ------
From: "Hachmann" <email address hidden>
To: <email address hidden>
Sent: 2/7/2018 7:13:15 AM
Subject: Re: [Question #664114]: Problem with General Display Units
Property not saving

>Your question #664114 on Inkscape changed:
>https://answers.launchpad.net/inkscape/+question/664114
>
>Hachmann posted a new comment:
>Can you please append the image that shows which option you selected to
>the linked bug report?
>
>Attachments do not work in the 'answers' section, but they do in bug
>reports. I do not know which option you selected.
>
>--
>You received this question notification because you asked the question.

Hachmann (marenhachmann) said : #6

Thanks, hope it's going to work for you, too!

Charles Cecil (clcecil) said : #7

Hachmann,
You will be happy to know that your solution worked. The General Display
units is now showing inches and the rulers are incremented in inches.
I appreciate all the time and work you put into solving this problem.
Thank you.

Chuck Cecil

------ Original Message ------
From: "Hachmann" <email address hidden>
To: <email address hidden>
Sent: 2/7/2018 7:09:37 AM
Subject: Re: [Question #664114]: Problem with General Display Units
Property not saving

>Your question #664114 on Inkscape changed:
>https://answers.launchpad.net/inkscape/+question/664114
>
> Status: Open => Answered
>
>Hachmann proposed the following answer:
>Hi,
>
>so this corresponds to https://bugs.launchpad.net/inkscape/+bug/1671691
>
>
>Until the bug is resolved, you can use this workaround:
>
>- Open File > Document properties
>- Open the 'viewbox' section in the first tab
>- Trigger the creation of a viewbox by adding 1 (or any other number)
>to one of the values, hit Enter
>- Fix it to its correct value by subtracting 1 (or any other number)
>from the value you modified previously, hit Enter.
>- Change the unit in the top right corner ('Display units')
>- Save
>- Close and open document
>
>--
>If this answers your question, please go to the following page to let
>us
>know that it is solved:
>https://answers.launchpad.net/inkscape/+question/664114/+confirm?answer_id=2
>
>If you still need help, you can reply to this email or go to the
>following page to enter your feedback:
>https://answers.launchpad.net/inkscape/+question/664114
>
>You received this question notification because you asked the question.

Hachmann (marenhachmann) said : #8

I am :) Thanks for letting me know.

Can you help with this problem?

Provide an answer of your own, or ask Charles Cecil for more information if necessary.

To post a message you must log in.