Unable to ungroup imported plots

Asked by Michael C Bellavia on 2018-01-30

Hello,

I had imported an SVG file of flow cytometry plots made in FloJo so that I can uncouple specific plots and improve their resolution for re-export. For some reason some of the subplots are free objects, while the majority is one large object (multiple plots, and seemingly random inclusion).

I'm new to Inkscape, so I've tried a few basic things: ctrl-A and ungroup, objects-> unlock all, deleting nodes in the XML editor, but nothing has worked. I can't pick and choose which objects are selected. Its probably something simple that I'm not aware of. Any suggestions would be welcomed. Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Hachmann
Solved:
2018-02-02
Last query:
2018-02-02
Last reply:
2018-01-31
Hachmann (marenhachmann) said : #1

Do the following to understand what kind of object you're dealing with:

1. Switch to Selector tool (keyboard: s)
2. Click on the object you cannot ungroup
3. Read what it now says in the status line at the bottom.

 -> Image? : It's a raster image, no chance of ungrouping. Edit with raster graphics editor, or find out how to export to vectors.
 -> Group? : Try ungrouping
 -> Masked? Clipped? : Try Object > Mask/Clip > Release
 -> ? : Let us know

Michael C Bellavia (mcb131) said : #2

Thank you for the prompt response!

So the area I want to break into several objects is recognized as a group of three objects in root (not in a layer). The Ungroup command doesn't seem to change anything. I've tried to draw a rectangle over a plot and clip, but that hasn't worked either.

What else would you recommend? Is there anyway for me to share a screenshot?

Hachmann (marenhachmann) said : #3

Ungroup. If need be, repeat the ungrouping until the group is ungrouped completely.

You can also use the 'Deep ungroup' extension in the 'Arrange' submenu for Extensions (when the object is selected).

Hachmann (marenhachmann) said : #4

(you did have the object selected, right?)

Michael C Bellavia (mcb131) said : #5

Yeah I'm sure I've selected the objects. I ran the ' Deep Ungroup' extension, and after several hours of runtime (1000+ objects, the program recognizes each tick mark and connecting line in the plots as an object) I received this message:

Traceback (most recent call last):
  File "ungroup_deep.py", line 281, in <module>
    effect.affect()
  File "inkex.py", line 283, in affect
    self.effect()
  File "ungroup_deep.py", line 274, in effect
    self._deep_ungroup(elem)
  File "ungroup_deep.py", line 259, in _deep_ungroup
    self._ungroup(node)
  File "ungroup_deep.py", line 203, in _ungroup
    self._merge_transform(c, node_transform)
  File "ungroup_deep.py", line 105, in _merge_transform
    simpletransform.formatTransform(this_transform))
  File "src/lxml/lxml.etree.pyx", line 1641, in lxml.etree.__ContentOnlyElement.set (src/lxml/lxml.etree.c:60474)
  File "src/lxml/lxml.etree.pyx", line 1637, in lxml.etree.__ContentOnlyElement._raiseImmutable (src/lxml/lxml.etree.c:60375)
TypeError: this element does not have children or attributes
--------------------------------------------------------------------------------------------------------------------------

Still no luck separating the plots. The number of objects decreased through, from 1164 to about 930. I'll rerun Deep Ungroup again to see if anything changes.

Hachmann (marenhachmann) said : #6

Oh wow, that file you have there must be really messed up...

If you can share the file, we could take a look if there's another option.

You could use any file hosting service for sharing your file (e.g. google drive, dropbox framadrop...).

Michael C Bellavia (mcb131) said : #7

I'm looking to separate the two vertical 'halves' into 4 plots (J5 Histograms, J5 Dotplots, O157 Histograms, and O157 Dotplots). I've been able to isolate the J5 Histograms and the O157 dot plots, but the half of the O157 histograms and the J5 dotplots are together in a massive group.

https://drive.google.com/file/d/1ZCXK3pUAProSAZgpDRye4mtAme4qUBa1/view?usp=sharing

Thank you for all your help!

Best Hachmann (marenhachmann) said : #8

The ungroup-takes-eternally issue seems to be fixed for Inkscape 0.92.3 - I used the stable branch development version, and ungrouping worked almost immediately, while it takes maybe half a minute with the stable version.

Deep Ungroup indeed does give an error, not sure why.

I'll send you a link to your re-grouped file in a private message, as you might not want your research results to be public already for longer than necessary.

Hachmann (marenhachmann) said : #9

> Thank you so much! It looks good on this end.
> Until version 0.92.3 is released, would you recommend I use a
> different software/could you estimate the release date?
> I don't want to have to bother you guys any time I'd want to reformat my figures.

What's your operating system?

And also what would you prefer using:
a) an outdated version with known bugs and issues,
b) a not-yet-released version with most certainly less bugs, but maybe a couple of new, unknown ones

(my answer will depend on yours)

Michael C Bellavia (mcb131) said : #10

Thanks Hachmann, that solved my question.

Michael C Bellavia (mcb131) said : #11

Sorry...didn't realize that message would auto-generate.

I'm using Windows 10 64-bit, but I have the 32-bit Inkscape 0.92.2 installed as the 64-bit seemed clunkier (lagging, etc.).

I think I'll go with Option b. I'd probably only use Inkscape to reformat and improve the resolution of these plots. And the yet-to-be-released version seems to do that without issue.

Hachmann (marenhachmann) said : #12

To get a current version from the stable development branch, visit

https://ci.appveyor.com/project/inkscape/inkscape/history

Then:

1. Click on the commit you want to use (you want the latest 0.92.x version)
2. then choose your architecture - 32 or 64 bit (corresponding to
"Environment: MSYSTEM=MINGW32" or "Environment: MSYSTEM=MINGW64")
3. then choose 'Artifacts' tab on the right above the black box
4. then download 7z-compressed file
5. unpack with 7zip
6. Run it

I really hope it solves the issue - it worked for me, but who knows...

To go back to an older version, visit https://inkscape.org/releases .

Michael C Bellavia (mcb131) said : #13

I tried to find the download for both the 32-bit and the 64-bit under the Artifacts tab but I don't see a link. The only download option I can find downloads a log file. Do I need a login for AppVeyor?

Thanks again!

Hachmann (marenhachmann) said : #14

If you could include a link to the actual page you are looking at, I could try to have a look at it, too.

Hachmann (marenhachmann) said : #16

You didn't select a 0.92.x version, but master, as it says right below the link to the log file. This is not what you want.

Anyway, there is a 7z file on that page (and on the ones for 0.92.x, too), right in the middle of the page, under the heading 'File name'.

But better select a 0.92.x version, as you probably do not want to deal with any new bugs or incomplete features in the development version.

Michael C Bellavia (mcb131) said : #17

Hello again,

So I've downloaded and installed the development version (64-bit architecture), and while it is smoother and easier to ungroup I still am unable to separate the top two plots from the bottom five, and the table can't be grouped. I'm sorry to keep passing these on to you, but is there something I'm missing? The link is below. Thank you again for all your efforts on my behalf.

https://drive.google.com/file/d/1rHmJoGtd_03BiRuq7mwHOYO1Mflia8MY/view?usp=sharing

Mc (mc...) said : #18

this file is protected

Hachmann (marenhachmann) said : #20

Unfortunately, you downloaded the non-recommended version. What you want is NOT the master branch, but the 0.92.x branch.
Please remove the master version, then install the latest 0.92.x version from the appveyor page I linked to, so we can correctly compare behavior between versions.

Currently, this is https://ci.appveyor.com/project/inkscape/inkscape/build/0.92.x-1027

When I open your file with the latest 0.92.x version, then select everything with Ctrl+A, then do Ctrl+Shift+G 6 times, until in the status line it says '1059 objects selected of types Path, Group, Text in root', and each element showing its own selection frame, I can move all relevant parts of the drawing independently.

Can you try that, please?

Hachmann (marenhachmann) said : #21

Sorry, there is no file available for that build.
Please try this one instead:

https://ci.appveyor.com/project/inkscape/inkscape/build/0.92.x-1020/job/mpbfg3hv5vqveygf/artifacts

Michael C Bellavia (mcb131) said : #22

Thank you! It finally worked. Sorry for any frustration. I really appreciate it!

Hachmann (marenhachmann) said : #23

Glad it worked and wasn't some kind of glitch specific to Inkscape's Windows version!
Best of luck with your antibodies ;-)