All Drawing Disappears When I Zoom In Past 1215%

Asked by Scott Kleinpeter on 2018-01-17

Hi All,

I'm working on some minute design details. I'm not using the grid, but I am using guides. I have many, many guides on the page. When I zoom in past 1215%*, all the content of my drawing disappears. The guides remain. If I activate the grid, the grid will display. When I zoom back to 1215%, the drawing reappears. Nothing is lost, it just disappears from the GUI. Also, when the drawing disappears, the paths disappear with the objects. (If an object is selected whenever I zoom in past 1215%, the paths of the object will still be available to manipulate; but if I deselect the object while zoomed in, the object disappears again until I zoom out.

*Exactly at 1216%, the drawing disappears.

Any help y'all can offer is deeply appreciated!

Thank you!

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Hachmann
Solved:
2018-01-18
Last query:
2018-01-18
Last reply:
2018-01-18
Scott Kleinpeter (scotticus5) said : #1

I'm sorry, the paths DO remain. I was mistaken in that.

Hachmann (marenhachmann) said : #2

Scott, as far as I know, there are known issues with parts of a text or pattern fills disappearing (from being visible) when zooming in.
As you say it's a path - does it have a pattern fill? There's a trick to mitigate the issue, if that's the case.

Can you share the SVG file and also tell us:
- your Inkscape version (Help > About)
- your operating system

For sharing a file, please use an online hosting service, such as dropbox, google drive, framadrop etc.
Email attachments will not work.

Scott Kleinpeter (scotticus5) said : #3

Hi Hachmann,

So, I'm running Inkscape 0.92
My OS is Windows 7 Home Premium w/ Service Pack 1
System type is 64bit

I'm not using any pattern fills (that I'm aware of).

Okay, this is the file I'm working on currently that has the trouble:
https://drive.google.com/file/d/14CclzuHMntklsk0017jE3thdR_rnn7gX/view?usp=sharing

And then, this is an earlier iteration of that file that doesn't have any trouble, for some reason:
https://drive.google.com/open?id=1Zsm51fcm1vmbVYKYNaKzsxWlYjL0BKHH

Thanks for your help!

Hachmann (marenhachmann) said : #4

The first file (the one with the issue) doesn't allow me to access it, unfortunately. Can you check the permissions?

Hachmann (marenhachmann) said : #5

Oh, and please tell us if you're using 0.92, 0.92.1 or 0.92.2.

Scott Kleinpeter (scotticus5) said : #6

Thanks for your quick response!

I believe this link of the file should be available to you:
https://drive.google.com/open?id=1jmhj2zepM5Cc1Vy7k1ulUpPWBoYQ5Wwe

And sorry or the vagueness about the vagueness, I just noticed this:
Inkscape 0.92.2 (5c3e80d, 2017-08-06)

Thanks again!

Best Hachmann (marenhachmann) said : #7

Nevermind, I get the issue with the 'B' file, too, when zooming in.

The issue seems to be related to the path with the id path104378 , which has some very large numbers in it and which extends beyond the possible canvas area, maybe when zoomed in, these numbers become too large to hold (or something...).

Delete it (open XML editor, enter Ctrl+F, then enter the path id from above, then delete the node in the XML editor by clicking the corresponding button with the x in the red box). Then zooming will work again.

I've made a bug report for this at https://bugs.launchpad.net/inkscape/+bug/1743913 (I removed everything from your picture, except for the broken straight-line path, so there's a test case).

You don't accidentally remember how you came to create that path?

Scott Kleinpeter (scotticus5) said : #8

Thanks, Hachmann! It worked like a dream!

I think that path appeared whenever I was experimenting with the measuring tool: I was trying to figure out how to get "convert to item" to work instead of "mark dimension" (because at the time, I still wasn't certain of the difference between the two; I just found I had the need for measuring distances). Also, I'm not sure if this makes a difference, but I had just started jumping out to 100% zoom by pressing "1" on my keyboard, and then rapidly zooming in by clicking the page-wheel on my mouse. I might have pressed a random key without realizing it.

Thanks again! This program is a marvelous tool! I really appreciate the work y'all do!

Scott Kleinpeter (scotticus5) said : #9

Thanks Hachmann, that solved my question.

Hachmann (marenhachmann) said : #10

You're welcome :)

If you ever feel like playing around with the measure tool some more, and achieve to make step-by-step instructions that lead to that too-large path (something like this is probably very hard to reproduce, and might need a lot of trial and error), please make a bug report over here: https://bugs.launchpad.net/inkscape .