Inkscape 0.92.2 won't run - Windows 10

Asked by David Abreu on 2017-10-17

I've downloaded Inkscape before, on version 0.91 and had so far been working perfectly. A few days ago I installed the new 0.92.2 and initially did not have any trouble, my old file converted seamlessly and I eve kept working on them. Yesterday I was working in one of my projects, but after I closed it I tried to open a new Inkscape file and it wouldn't start. I've tried uninstalling and reinstalling inkscape but it wouldn't run.

What I've so far noticed through the Task Manager seems to indicate the program crashes when initially trying to run, yet I'm unsure. What I've noticed is the task appears as running but after a couple of seconds it vanishes from the Manager process window.

Any idea on what might be happening and how to fix it?

Question information

Language:
English Edit question
Status:
Open
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2017-10-21
Last reply:
2017-10-18
Hachmann (marenhachmann) said : #1

An idea:
Have you installed a new font in between Inkscape program starts? There is a known issue with font files with some strange markup crashing Inkscape.

If so, the known workaround is to uninstall the offending font.

Another idea:
Could there be a weird file name in the 'recently used' list?
E.g. something with characters different from 0-9 a-z A-Z -_ ?

If so, it's possible to delete that list, I'd have to research where it can be found...

Else, please run 'inkscape.com' or 'inkscape' on the command line, to get some error output.

Hachmann (marenhachmann) said : #2

Or have you installed a new software, in between?

David Abreu (dabreu) said : #3

I installed the new version of GIMP, but after I installed it, I still could run Inkscape without problem.

Hachmann (marenhachmann) said : #4

Did you check for the other two issues (see my first comment) or run Inkscape from the command line to get some info?

David Abreu (dabreu) said : #5

I did uninstall a couple of fonts I had got recently yet it wouldn't run. When I write the command it wouldn't open either and it wouldn't show an error message either. I have reverted to the 0.91 version and it works find, so the problem must be with the 0.92.2 version.

Regarding the Recently Used list, some files use parenthesis () and spaces} but as I said before, they work fine in 0.91

David Abreu (dabreu) said : #6

I've changed the names of all the files on the Recently Used lists and it still wouldn't run.

Hachmann (marenhachmann) said : #7

Mmh, no error message - that's unfortunate... :/

Wish we could tag developers here...

Can you convert this question into a bug report?

David Abreu (dabreu) said : #8

Sure, will do.

Hachmann (marenhachmann) said : #10

Thanks!

Can you help with this problem?

Provide an answer of your own, or ask David Abreu for more information if necessary.

To post a message you must log in.