Colour bucket not using fill colour.

Asked by Johannes Veje on 2017-09-26

I am trying to fill in colours using the colour bucket, but it does not appear to use the fill colour.
I have taken a 10 sec screen capture to show what is happening: https://youtu.be/O1HXvz_BOpE
Can anyone tell me if I should do something differently or whats happening?

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Johannes Veje
Solved:
2017-09-28
Last query:
2017-09-28
Last reply:
2017-09-27
Hachmann (marenhachmann) said : #1

Have you set the tool's style to 'last used style' or to 'this tool's own style'? Double-click on the bucket icon to find out.

Johannes Veje (veje-johannes) said : #2

I had it on 'last used style' - the local translation did not make that clear. It does however spark a new question of how to change the tool's own style, and why the style is even shown if it is not used for anything?

Hachmann (marenhachmann) said : #3

If on 'last used style', it should use the last used style, or the one you set by clicking on any color in the palette before you use the tool.
I just tested with Inkscape 0.92.2 and it works as described here:

So, step by step:

- set to 'last used style'
- deselect everything
- switch to bucket tool
- select a color in the palette
- click on drawing to fill an area

To change to the tool's own style (which will be constant until you set it again via the same way), select an object with the desired style, select the radio button for 'this tool's own style' and click 'take from selection'.

Johannes Veje (veje-johannes) said : #4

I tried the approach and it does indeed work when selecting a colour from the palette, it does however not work when using the pipette tool to chose the colour.

Hachmann (marenhachmann) said : #5

That works for me, too...

1. Select dropper tool ('pipette')
2. Click on a color in drawing to set fill color
3. Switch to bucket tool
4. Click on drawing to fill an area

Did you do it this way? What is your operating system and Inkscape version?

Johannes Veje (veje-johannes) said : #6

Yes I did it that way and I worked. However I tested it more and it turns out my problem was if I used the dropper tool on one instance of Inkscape the other instance would show the colour, but not use it. I don't know if that should be considered a bug, or just weird.

Hachmann (marenhachmann) said : #7

Ah, now I can confirm.

I think it shouldn't work that way, but display the color that will /really/ be used.
Can you make this a bug report? (with step-by-step instructions, and Inkscape version - Help>About in Inkscape).

Johannes Veje (veje-johannes) said : #8

I'll do it first thing Monday morning!

Hachmann (marenhachmann) said : #9

Have a great weekend, Johannes!