I cannot open .dxf files from Inkscape in other programs like VCarve Pro.

Asked by RedEngine

I am using Inkscape at home to design objects for toolpathing in VCarvePro (I do not have a license to use VCarve at home.) Supposedly VCarve will open a .dxf file, but it will not open the .dxf files that I am saving in Inkscape. Is there any workaround for this?

VC "sees" the .dxf files as available for opening, but when I click on them to open, nothing happens.

(PS I tried saving my Inkscape files in .pdf but parts of them get mangled when VCarve opens them and I have to do a lot of cleanup.)

Question information

English Edit question
Inkscape Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
RIco (rico-rootscore-deactivatedaccount) said :

you are probably on windows, so try a development build as some work has been done on the dxf export, it might work better for you

here you'll find new development builds every few days for windows:

you'll see Inkscape20XXX files.. the biger the number .. the more recent (check the dates as well). You'll need 7zip to unpack them.

Revision history for this message
RedEngine (cruzetti) said :

I tried a few builds, the latest one and a couple of older ones. No joy; the dxf crashes VCarve when I try to open it, and even if I open the brand-new dxf file in Inkscape again, it is distorted. :(

Revision history for this message
Oleg Koptev (koptev-oleg) said :

Red Engine - I confirm that.

Inkscape produce severly damaged dxf. with simple forms all correct, but with complicated paths things are very bad.
I don't know 'bout VCarve, but in AutoCAD dxf opens like a garbage. I think you need to bugreport it.

Revision history for this message
Alvin Penner (apenner) said :

probably the best thing to do is to file a bug report at https://bugs.launchpad.net/inkscape .
This will allow you to attach the .svg file that you would like to convert to .dxf so that it can be tested with the latest version of Inkscape.

Can you help with this problem?

Provide an answer of your own, or ask RedEngine for more information if necessary.

To post a message you must log in.