Doc setup will not stay in inches. reverts to px

Asked by Robert Hazelton on 2017-04-20

I have been using Inkscape for two years and never had a problem. My older version became unstable and would not load. I downloaded the ver 92.1 and am now having problems with the document setup. I do everything in inches and feet to convert to the CNC plasma cutting programs. Inkscape will not stay in the inches mode. It reverts back to px and has open all my existing images in px. I have tried to change all dialog boxes to inches but the program goes back to px's. How do I fix this to stay in the inches unit of measurements and display?

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
TylerDurden
Solved:
2017-04-28
Last query:
2017-04-28
Last reply:
2017-04-25
TylerDurden (8thrule) said : #1

Presuming you are opening older files?

This is likely related to bug report:
https://bugs.launchpad.net/inkscape/+bug/1671059

Plus two other reports noted in the above.

I suggest adding your voice to the bug report, and an example file for the devs to review.

In the meantime, you might try pasting your objects into a new file (after scaling to 96dpi).

Regards,
TD

Robert Hazelton (sfmetalworks) said : #2

Thanks you your interest in this issue. I thought about paste idea this morning and will give that a try later today. Thanks again.

Sent from my Verizon 4G LTE smartphone

-------- Original message --------
From: TylerDurden <email address hidden>
Date: 4/20/17 1:08 PM (GMT-08:00)
To: <email address hidden>
Subject: Re: [Question #624758]: Doc setup will not stay in inches. reverts to
  px

Your question #624758 on Inkscape changed:
https://answers.launchpad.net/inkscape/+question/624758

    Status: Open => Answered

TylerDurden proposed the following answer:
Presuming you are opening older files?

This is likely related to bug report:
https://bugs.launchpad.net/inkscape/+bug/1671059

Plus two other reports noted in the above.

I suggest adding your voice to the bug report, and an example file for
the devs to review.

In the meantime, you might try pasting your objects into a new file
(after scaling to 96dpi).

Regards,
TD

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/inkscape/+question/624758/+confirm?answer_id=0

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/inkscape/+question/624758

You received this question notification because you asked the question.

Robert Hazelton (sfmetalworks) said : #3

Yes. And a new problem is when the file is saved as a DXF file. The scale
size is not correct. The images come out smaller than drawn.

On Apr 21,e 2017 8:08 AM, "Robert Hazelton" <
<email address hidden>> wrote:

> Your question #624758 on Inkscape changed:
> https://answers.launchpad.net/inkscape/+question/624758
>
> Status: Answered => Open
>
> You are still having a problem:
>
>
> Thanks you your interest in this issue. I thought about paste idea this
> morning and will give that a try later today. Thanks again.
>
>
> Sent from my Verizon 4G LTE smartphone
>
> -------- Original message --------
> From: TylerDurden <email address hidden>
> Date: 4/20/17 1:08 PM (GMT-08:00)
> To: <email address hidden>
> Subject: Re: [Question #624758]: Doc setup will not stay in inches.
> reverts to
> px
>
> Your question #624758 on Inkscape changed:
> https://answers.launchpad.net/inkscape/+question/624758
>
> Status: Open => Answered
>
> TylerDurden proposed the following answer:
> Presuming you are opening older files?
>
> This is likely related to bug report:
> https://bugs.launchpad.net/inkscape/+bug/1671059
>
> Plus two other reports noted in the above.
>
> I suggest adding your voice to the bug report, and an example file for
> the devs to review.
>
> In the meantime, you might try pasting your objects into a new file
> (after scaling to 96dpi).
>
> Regards,
> TD
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/inkscape/+question/624758/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/inkscape/+question/624758
>
> You received this question notification because you asked the question.
>
> You received this question notification because you asked the question.
>
--
Thank you,
Robert Hazelton

*Smoke & Fire Metal Works*
(702) 902-0932

Best TylerDurden (8thrule) said : #4

Ok, good that the paste is a viable workaround for that issue.

WRT the scale issue, there may be an updated dxf/plotter extension found in the report here:
https://bugs.launchpad.net/inkscape/+bug/1672066

I'd rename your current extension to dxf_outlines.py_OLD and install the updated dxf_outlines.py to your user profile extensions directory. (..Users\yourname\AppData\Roaming\inkscape\extensions\

Chime back and let us know how that works out.

TD

TylerDurden (8thrule) said : #5

PS if the scale is only slightly smaller, you could try the Extensions>Document>90 to 96 dpi.

TD

Robert Hazelton (sfmetalworks) said : #6

I thank you for your help on this. Unfortunately I have no idea where to
start with installing and fixing bugs. I am not from the computer age. I
don't know what all the different files means and extensions are for or how
to work them. Maybe I need to buy a different program that will work
correctly and trash Inkscape?

Thank you,
Robert Hazelton

*Smoke & Fire Metal Works*
(702) 902-0932

On Sun, Apr 23, 2017 at 8:03 AM, TylerDurden <
<email address hidden>> wrote:

> Your question #624758 on Inkscape changed:
> https://answers.launchpad.net/inkscape/+question/624758
>
> Status: Open => Answered
>
> TylerDurden proposed the following answer:
> Ok, good that the paste is a viable workaround for that issue.
>
>
> WRT the scale issue, there may be an updated dxf/plotter extension found
> in the report here:
> https://bugs.launchpad.net/inkscape/+bug/1672066
>
> I'd rename your current extension to dxf_outlines.py_OLD and install the
> updated dxf_outlines.py to your user profile extensions directory.
> (..Users\yourname\AppData\Roaming\inkscape\extensions\
>
> Chime back and let us know how that works out.
>
> TD
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/inkscape/+question/624758/+
> confirm?answer_id=3
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/inkscape/+question/624758
>
> You received this question notification because you asked the question.
>

TylerDurden (8thrule) said : #7

If you would like to keep using Inkscape, there are usually folks willing to help, but it might involve re-installing Inkscape and putting some additional files into the Inkscape folders. It's not very complicated, but no guarantees that everything works as expected. This is (free) open-source software after all.

Other software options include Adobe Illustrator and CorelDraw, which can output dxf files for CNC and CAM.

Robert Hazelton (sfmetalworks) said : #8

How do I go about installing the dfx_outlines.py file that is linked in the bug report you sent me? I am unsure of how to install that. Do I simply make a text file of it and put it into Appdata\Roaming\inkscape\extensions or do I need to run this from the command line? If it is from the command line what is the command needed to get the script to run and install properly?

Thanks

TylerDurden (8thrule) said : #9

I would just put it in that folder (no need to convert it to text).

Also you probably should put its helper file in there too. (dxf_outlines.inx)

You can use this one, it seems to work for me:
https://dl.dropbox.com/s/z2qgb9454b42y9b/dxf_outlines.inx

You will want to re-start Inkscape after adding the two extension files. These files should override the "stock" files in the program folder.

TD

Thanks TylerDurden, that solved my question.

Thanks, the dxf_outlines.py file solved the problem. Thanks for your patience and all your help.