Feature request: Option for object size to NOT include border thickness.

Asked by Geoff on 2017-04-13

As a teacher and designer of rulers and shapes stencils, it is often necessary for me to specify an object's dimensions WITHOUT the border included. Currently this is impossible in Inkscape. e.g. If I draw a 10 mm square to be cut out of a plastic stencil I am designing, and draw this with a 1 mm thick border, the bit to be cut out will only measure 8 mm x 8 mm, as the border's thickness is taken into account in an objects dimensions. Hence I must draw a square of dimensions 12 mm x 12 mm if I am using a 1 mm thickness stroke. If I then change the stroke thickness, the dimensions of the shape change. My point is: The dimensions of a shape should NOT depend on the stroke/border thickness. It is the object's area without the border included that is most important. A border is just an aid to seeing an object's outline - it should not affect the object's dimensions.
There should be an option to exclude any border when measuring or specifying an object's dimensions. For example, when using the "Extension/Visualise path/Measure path" command, the area of the border is included in calculations. Furthermore, an option to align a border to the inside, outside or middle of an area's edge would be great. I believe Illustrator has such an option.

Question information

Language:
English Edit question
Status:
Open
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2017-04-14
Last reply:
2017-04-14
TylerDurden (8thrule) said : #1

Perhaps you have seen the setting in Preferences for "Geometric Bounding Box"? It's on the very first page of Preferences>Tools.

As for stroke inset/center/outset; you can add your "me too" here:
https://bugs.launchpad.net/inkscape/+bug/170898

TD

Hachmann (marenhachmann) said : #2

Hi Geoff,

this need you have (which is useful for many crafting uses of Inkscape like plotting, lasercutting, etching,...) has already been taken care of with the option you can find at Edit -> Preferences -> Tools: geometric bounding box.
(not tested with the extension, please test if it works as expected after changing the setting)

As for the alignment options, please take a look at the dialog you can find at Object -> Align and Distribute, and also at the snapping options in the snap tool bar at the far right of the Inkscape window (they manual section about them is a bit outdated, here's a more recent description of how snapping works in Inkscape from 0.91 on: https://inkscape.org/en/~Moini/%E2%98%85snapping-guide-091).

Inkscape has many features (also many bugs, of course). Don't hesitate to ask for help, here or at inkscapeforum.com, when you can't find a way to do what you want to do. Also there are many other helpful resources that you can find listed from https://inkscape.org/en/learn/ .

Kind Regards,
 Maren

Hachmann (marenhachmann) said : #3

Ah, misread the alignment thing, thanks, Tyler!
Maybe the paint-order (in stroke style tab of fill-and-stroke dialog) can help with that (a bit), too?

Geoff (gphillips) said : #4

Thanks heaps Tyler - much appreciated! I missed that section - was looking
at sub-menus of preferences.
Geoff..

Kind regards

Geoff Phillips
8 Wattle Tree Avenue
Wonga Park 3115
Ph. 0401 218 844
<email address hidden>

On Fri, Apr 14, 2017 at 11:22 AM, TylerDurden <
<email address hidden>> wrote:

> Your question #618904 on Inkscape changed:
> https://answers.launchpad.net/inkscape/+question/618904
>
> Status: Open => Answered
>
> TylerDurden proposed the following answer:
> Perhaps you have seen the setting in Preferences for "Geometric Bounding
> Box"? It's on the very first page of Preferences>Tools.
>
> As for stroke inset/center/outset; you can add your "me too" here:
> https://bugs.launchpad.net/inkscape/+bug/170898
>
> TD
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/inkscape/+question/618904/+
> confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/inkscape/+question/618904
>
> You received this question notification because you asked the question.
>

Geoff (gphillips) said : #5

Hi Maren. After changing setting to Geometric bounding box, Measure area
extension doesn't work anymore - even after changing it back to Visual!
Aaarghh!
Regards, Geoff.

Kind regards

Geoff Phillips
8 Wattle Tree Avenue
Wonga Park 3115
Ph. 0401 218 844
<email address hidden>

On Fri, Apr 14, 2017 at 11:28 AM, Hachmann <
<email address hidden>> wrote:

> Your question #618904 on Inkscape changed:
> https://answers.launchpad.net/inkscape/+question/618904
>
> Hachmann proposed the following answer:
> Hi Geoff,
>
> this need you have (which is useful for many crafting uses of Inkscape
> like plotting, lasercutting, etching,...) has already been taken care of
> with the option you can find at Edit -> Preferences -> Tools: geometric
> bounding box.
> (not tested with the extension, please test if it works as expected after
> changing the setting)
>
> As for the alignment options, please take a look at the dialog you can
> find at Object -> Align and Distribute, and also at the snapping options
> in the snap tool bar at the far right of the Inkscape window (they
> manual section about them is a bit outdated, here's a more recent
> description of how snapping works in Inkscape from 0.91 on:
> https://inkscape.org/en/~Moini/%E2%98%85snapping-guide-091).
>
> Inkscape has many features (also many bugs, of course). Don't hesitate
> to ask for help, here or at inkscapeforum.com, when you can't find a way
> to do what you want to do. Also there are many other helpful resources
> that you can find listed from https://inkscape.org/en/learn/ .
>
> Kind Regards,
> Maren
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/inkscape/+question/618904/+
> confirm?answer_id=1
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/inkscape/+question/618904
>
> You received this question notification because you asked the question.
>

Geoff (gphillips) said : #6

My apologies - area measurement was hidden under border!
G

Kind regards

Geoff Phillips
8 Wattle Tree Avenue
Wonga Park 3115
Ph. 0401 218 844
<email address hidden>

On Fri, Apr 14, 2017 at 11:28 AM, Hachmann <
<email address hidden>> wrote:

> Your question #618904 on Inkscape changed:
> https://answers.launchpad.net/inkscape/+question/618904
>
> Hachmann proposed the following answer:
> Hi Geoff,
>
> this need you have (which is useful for many crafting uses of Inkscape
> like plotting, lasercutting, etching,...) has already been taken care of
> with the option you can find at Edit -> Preferences -> Tools: geometric
> bounding box.
> (not tested with the extension, please test if it works as expected after
> changing the setting)
>
> As for the alignment options, please take a look at the dialog you can
> find at Object -> Align and Distribute, and also at the snapping options
> in the snap tool bar at the far right of the Inkscape window (they
> manual section about them is a bit outdated, here's a more recent
> description of how snapping works in Inkscape from 0.91 on:
> https://inkscape.org/en/~Moini/%E2%98%85snapping-guide-091).
>
> Inkscape has many features (also many bugs, of course). Don't hesitate
> to ask for help, here or at inkscapeforum.com, when you can't find a way
> to do what you want to do. Also there are many other helpful resources
> that you can find listed from https://inkscape.org/en/learn/ .
>
> Kind Regards,
> Maren
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/inkscape/+question/618904/+
> confirm?answer_id=1
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/inkscape/+question/618904
>
> You received this question notification because you asked the question.
>

Hachmann (marenhachmann) said : #7

No problem - glad it works now :)

Can you help with this problem?

Provide an answer of your own, or ask Geoff for more information if necessary.

To post a message you must log in.