Manual kerning not working despite trying all suggestions found.

Asked by Louise

I'm trying to play around with manual kerning in Inkscape a bit, but pressing ALT + up/down arrow doesn't work. The cursor moves left or right as though ALT wasn't pressed at all. I've checked Inkscape's preferences and unselected all the options under 'Input'. I've also checked and double-checked that the text I've selected is "Unflow"ed.

I'm using an iMac with Mac OS X version 10.5.6 but I am totally new to using Macs and Inkscape - I've been Googling this problem for a while and found some scary suggestions about keyboard things, like changing the layout or something? It does look like Inkscape is ignoring both of my alt keys (I tried both sides and every combination of ctrl, alt, cmd and shift) so does this mean it's more of a keyboard settings problem than an Inkscape one?

Thanks in advance for any help :)


Question information

English Edit question
Inkscape Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
RIco (rico-rootscore-deactivatedaccount) said :

are you using inkscape with X11?
if yes try updating X11 to the latest version in the following link. There was similar keyboard problems in gimp that got fixed by updating X11, it might as well work for inkscape.

If you think it might be a bug, you can eventually try a development version of inkscape for osx, the bug might have been fixed:

i hope this is of some help.

Revision history for this message
Louise (lnwhitmore) said :

Thanks for the links, I did need to upgrade X11 and I'm happy using the newest Inkscape version. So that was all good stuff :)

My personal kerning issues turned out to be an X11/keyboard thing. Sorry I don't understand Macs enough to explain very well! But this link sorted the problems: - I think I was blaming the wrong thing to begin with. :)

Yay, kerning!