Node stroke width handles in the way

Asked by Charles Geiler on 2017-01-26

I just migrated from version .91 to .92 and am having some growing pains. I'm hoping that there is a simple solution.

1) When using the node edit tool, I'm having a very hard time grabbing the node I want to reposition. The handle for the stroke width keeps getting in the way. Is there a way to turn off that handle (or ignore it when trying to grab the actual node)?

2) When I open an inkscape svg file saved with .91, my pattern-to-paths effects have disappeared from their strokes. It's as if the stroke-to-path command was run on them. Is there a way to get the original pattern back?

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Hachmann
Solved:
2017-02-02
Last query:
2017-02-02
Last reply:
2017-01-26
Hachmann (marenhachmann) said : #1

Hi Charles,

1. ) So it seems you're by default creating paths with an LPE applied to them.
Do you need variable stroke width? Or are those all Pattern-along-Path LPEs?

As far as I know it's not currently possible to deactivate that width handle, no. If you like, you can make a feature request for it.

2.) Sorry, I'm not sure I get it. Can you upload a couple of screenshots and files to demonstrate the issue? (if you don't know where to upload, you can use imgh.us - please only add links to your next comment, as this section does not support attachments).

Kind Regards,
 Maren

Charles Geiler (whozaa) said : #2

So there's a couple different issues here that aren't related and in retrospect I probably shouldn't have put them both in one post.

1)I have a simple stroke. If I select the node tool, then click the stroke, I see a node at each end of the stroke. I would like to click and drag one of the nodes to a different spot on the canvas, but the width handle is partially covering the node. So I end up accidentally altering the width instead of grabbing the node itself.
Since I first posted the question, I've discovered that this only happens if I open an svg saved with .91 and try to edit a stroke already in it. If I draw a new stroke in a new file with .92, the width handle isn't there and I don't have the same problem.

2) Some time ago I wanted to create an image of an electrical wire that was easy to bend in several different directions. So I created an LPE that was just a long skinny rectangle, and applied it to a path. This way I could use all the path type tools (bend, stretch, snap) on it and it worked wonderfully for my needs. I found that I could copy and paste the LPE'd stroke into several drawings without having to recreate the pattern each time. So now I have several drawings that use the same LPE'd stroke.
After I migrated to .92, if I open a drawing saved under .91, the LPE is no longer there. It's changed from a patterned stroke into the skinny rectangle, as if I had used the stroke-to-path command. At first glance it looks exactly the same. But if you use the node edit tool, you can see that it's no longer a patterned stroke. It's an object in the shape of the original skinny rectangle. So to move or bend it, I would have to manipulate several nodes at once or use some combination of transforms.
Since I first posted, I've discovered that this only happens if the patterned stroke is inside a copy of a group. If the stroke is by itself, it stays a stroke.

Here's a link to my dropbox with an example of what I'm doing. You'll see that each electronic component has a grey wire sticking out. Those wires are (supposed to be) single strokes with the grey rectangle pattern applied. If you copy and paste one of the components, and then use the node edit tool to look at the grey wires sticking out, you'll see that they're not single strokes anymore.
I also used the same pattern to create the wires that connect everything together; they just have a different fill color. But they seem to be unaffected when I copy and paste them.

https://www.dropbox.com/s/9qobl7wb016ww1h/Clean.svg?dl=0

Hachmann (marenhachmann) said : #3

1.) A simple stroked path does not have a width handle. If there is a width handle that changes the stroke width if you drag on it, then the path has a path effect applied. Remove by going to Path -> Remove path effect, and set a stroke instead via fill+stroke dialog. If you want the LPE, then the width handle is currently not optional. Zooming in may help to discern handle from node.

2.) It would be easier for me to understand if we could agree on the same terminology... :-(

A path is the thing that consists of nodes that are connected by path segments.
A stroke is just the contour rendering of the path, which can have a specific color or width, and is centered on the path.

Copy-pasting of path effects (via 'paste path effect' in the menu) is broken in 0.92 (not sure if this has anything to do with your issue, though).

As for the wires, I can't find the difference you're describing... For me, even in 0.92, all the wires I tried are open paths with a Pattern-Along-Path LPE applied to them.

Can you specify the id of a path that has the effect applied but that seems to be have been turned to path?

There seems to be something problematic, though, with the file (or with Inkscape). I've had Inkscape crash on ungrouping... :-(

Btw. it looks as if it has been made with a lot of diligence, esp. the wound wires that split later on :) (what will it be? An amplifier, maybe?)

Charles Geiler (whozaa) said : #4

1) Thanks for clarifying that for me. I still wish the width handle could be disabled or ignored, but I am willing to accept the current behavior. We can consider this question closed.

2) I'm sorry for not using the right terminology. I tend to think of a stroke and a path as the same thing. But you're absolutely right that they're not.

Try looking at the linked file. I've copied one of the electrical components so that you can see the behavior directly. The original is ID#g4537-80 and its copy is ID#g4537-80-2. So far, I haven't had any stability issues with .92 so I don't know why yours is crashing. Version .91 would crash fairly regularly on me, usually while copying/pasting groups. But I got in the habit of saving after every major step, and the autosave-on-crash feature was usually pretty reliable.

https://www.dropbox.com/s/9bm8dpl2l5okome/Clean2.svg?dl=0

You're correct that it's an amplifier. I am designing a modular guitar amplifier system and this is the drawing for one of the modules. Wire routing and component placement are very important to get the best sound out of the amplifier. And a drawing like this helps you plan out every detail of the design.

Best Hachmann (marenhachmann) said : #5

So, when I open that same file with 0.91 (I've got both versions installed), then I can see that the wire you're referring to already is a path with 4 nodes, instead of the 2-node path with PaP-LPE.

See http://i.imgur.com/jKTmqmA.png

So if this is the 'original' file, that hasn't been edited with 0.92, then you must have accidentally converted the object to path already in 0.91 (or you hit a bug there that did the conversion). Unfortunately, I can't tell when this might have happened - only you know the dates on your files, and if you edited with 0.92 or not.

Edit: I think I now got what you mean. You copy-paste the group in 0.92, and then the LPE is gone. I think this is really related to the bug I mentioned about pasting Path effects.
You can test if the 0.92.1 pre0 prerelease fixes the issue (as Jabier, who is into Path effects, has presumably fixed the bug). Download the 7zip file from https://inkscape.org/en/download/development-versions/ (scroll down to find).

As a workaround, you can also just duplicate with Ctrl+D. This will keep the LPE (but testing would still be helpful, to see if all cases have been covered).

Inkscape crashes fairly often for me, probably because I often open problematic files, or do some weird testing, that drives it to its max ;-) (did you know that there's also a timed auto-save feature hidden in the preferences? It's the first thing I change, i.e. activate, when I've got a new Inkscape installed).

As for the terminology, it's just more difficult for a non-native speaker to guess correctly :)

Charles Geiler (whozaa) said : #6

"Edit: I think I now got what you mean. You copy-paste the group in 0.92, and then the LPE is gone."

Yes, that's it exactly! I agree that it might be related to the copy-paste path effect issue that you mentioned. I won't submit a bug report since its a known problem.

The duplicate function works perfectly so I will just use that instead of copy/paste. Thank you very much for your help! I'm marking this as "solved".

Charles Geiler (whozaa) said : #7

Thanks Hachmann, that solved my question.