cannot build inkscape (uristream.cpp error)

Asked by Ahmad Dendi Dwipayana on 2008-07-10

I'm trying to build inkscape on archlinux, configure seems to work but it failed when i run 'make'.

here is the error message:

dom/io/uristream.cpp: In member function ‘void org::w3c::dom::io::UriInputStream::init()’:
dom/io/uristream.cpp:102: error: ‘strlen’ was not declared in this scope
make[2]: *** [dom/io/uristream.o] Error 1
make[2]: Leaving directory `/home/dendi/Downloads/Apps/inkscape-0.46/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/dendi/Downloads/Apps/inkscape-0.46'
make: *** [all] Error 2

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Ahmad Dendi Dwipayana
Solved:
2008-07-11
Last query:
2008-07-11
Last reply:

i wonder is it because i use gcc 4.3.1?

i managed to pass this error by commenting line 102 on uristream.cpp..
but i haven't successfully compile inkscape because of the pdf-parser issue.. [1]

[1]https://bugs.launchpad.net/inkscape/+bug/239379

i ended up using the svn version.. and there seems to be no problem.

ishmal (ishmalius) said : #4

Yes, strlen() is gone in the current svn version. Also, that pdf-parser.cpp problem is solved by adding POPPLER_NEW_GFXFONT to CFLAGS, like:

./configure CFLAGS="-DPOPPLER_NEW_GFXFONT" (and anything else you need)