How to disable zoom into area (Shift+MMB drag)?

Asked by OVERD on 2015-02-26

When I use Tweak tool to change objects shapes, I`m using Ctrl and Shift modifiers. And I`m also press middle mouse button to pan on canvas. And the problem is that very often I accidentally press Shift and MMB and move mouse in the same time which activates area zooming. And because the selected area is extremely small (a few pixels), Inkscape try to load necessary data into RAM to render this and become to use all of my PC RAM in less than 10 seconds (I use Inkscape x64 on Win 8.1 with 8Gb of RAM). It looks like a huge memory leak, and in the worst case my PC needs to reboot because it stops to answer on any commands.

Is there some way to disable this shortcut to avoid the problem?

Question information

Hachmann (marenhachmann) said : #1


I don't have a current Inkscape version here to check, so I'm not sure if this will help you:
Maybe the keyboard shortcut editor allows to set this?


OVERD (tyssoq) said : #2

I`ve tried to search this into Preferences->Interface->Keyboard shortcuts. But it seems that this shortcut editor only contain keyboard keys and not allow to change any mouse buttons functions or shortcuts that require mouse movement (for example, press Space and drag mouse to pan).
And I forgot to say that I use blur filter which causes high memory consumption when zooming in. I`ve already had a few times when I lost my unsaved data due to accidental activation of zooming into area.

su_v (suv-lp) said : #3

> And I`m also press middle mouse button to pan on canvas

In Inkscape 0.91, you can pan by pressing the spacebar and moving the mouse (without pressing any mouse button) - does this work within the tweak tool context too?

Can you help with this problem?

Provide an answer of your own, or ask OVERD for more information if necessary.

To post a message you must log in.