probleme format svg (expert)

Asked by bonnet florent on 2013-04-29

Bonjour voici mon porbleme :

je veut que mont format xml soit comme cela --> <path id="04" d="M 81.182569,64.620085 149.44786,84.009331 C 149.92081,84.517375 152.76737,84.539033 151.79002,91.955705 150.81517,99.353425 148.76423,97.61649 147.46022,97.561035 L 77.386084,76.908891 C 77.386084,76.908891 73.833613,73.999619 75.323944,69.171236 76.814276,64.342854 81.182569,64.620085 81.182569,64.620085 z" fill="#c0c0c0" stroke="#808080" stroke-width="0.6" />
 cependant j'ai un style qui englobe les attribut comme ceci et sa ne marche pas pour l'interaction --> <path d="m 211.12188,244.06897 2.52538,76.26652 45.96194,-14.14214 -11.11167,-72.2259 -37.37565,10.10152" id="002" style="fill:none;stroke:#000000;stroke-width:1px;stroke-linecap:butt;stroke-linejoin:miter;stroke-opacity:1" />

comment faire pour changer comme le premier exemple?

Question information

Language:
French Edit question
Status:
Answered
For:
Inkscape Edit question
Assignee:
jazzynico Edit question
Last query:
2013-04-29
Last reply:
2013-05-08
jazzynico (jazzynico) said : #1

Bonjour,

Par défaut, Inkscape enregistre toujours les attributs de style dans l'attribut style (façon CSS).

Pour conserver les attributs séparés, vous devez enregistrer le document en SVG Optimisé (Fichier>Enregistrer Sous>SVG Optimisé). Vérifiez juste que dans les paramètres d'exportation que l'option Style en XML soit bien cochée.

bonnet florent (flor7nt) said : #2

bonjour jazzy nico,

merci d'avoir répondu.
néanmoins j'ai un autre souci maintenant:

En effet j'ai bien réussi a séparer les attributs avec votre méthode, cependant mes coordonnée dans l'attribut "d" est aussi optimiser et met des virgule a la place d'un espace et me fait planter sur mon logiciel détectant un souci de coordonnée
ex--> d="M 258,987.25,984.65 (X,Y)......... au lieu de d="M 81.18,84.51 152.76 (X Y)

voici ce que cela me donne en reel:

  <path id="002" stroke-linejoin="miter" d="m210.11,243.06,4.5457,76.772,44.952-14.142-11.617-71.721-37.881,9.0914" fill-opacity="0.01357466" stroke="#000" stroke-linecap="butt" stroke-width="1px" fill="#000"/>

Si je remplace les virgules entre les X,Y par des espace sa fonctionne

jazzynico (jazzynico) said : #3

Bonjour Florent,

L'optimisation du chemin n'est en effet pas optionnelle lorsque vous enregistrez sous SVG optimisé. Le chemin est en effet différent, mais conforme aux spécifications du format SVG. Si vous ouvrez votre fichier avec Firefox ou Batik, il doit s'afficher correctement, sans erreur.
Avec quel programme essayez-vous (sans succès) d'ouvrir le fichier optimisé ?

bonnet florent (flor7nt) said : #4

bonjour jazzy nico,

sublime text 2 et/ou notepad++ pour visualiser le svg en code. ensuite ce SVG je l'exploite sous WINDEV et il m'indique qu'il y a un soucis de coordonné et quand je le retravaille sur notepad (en ajoutant les espaces) cela fonctionne

Can you help with this problem?

Provide an answer of your own, or ask bonnet florent for more information if necessary.

To post a message you must log in.