tool functions do not work.

Asked by pat gibbs on 2008-01-18

I can open Inkscape but when I click on tool icons, the icon comes up but will not function. Also, can not import old svg files (window says failed to load document) that I did earlier into inkscape. Can import bmps.
Inkscape worked fine for a while then I started having problems. I removed it from programs then reinstalled it. Tool functions worked for a while (though I still could not import old svg files) then they stopped working.

Question information

Language:
English Edit question
Status:
Answered
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2008-01-23
Last reply:
2011-01-27

This question was reopened

Ryan Lerch (ryanlerch) said : #1

Can you provide some more information for us?

What version of inkscape are you using?
What operating system are you using?
Also, screenshots and or screencasts of the behaviour are always helpful

pat gibbs (patgb) said : #2

I think it is 0.45.1

I use Windows XP

I don't know how to do the third request...screenshots, etc.

I removed the program after I asked the question (#22454) and then downloaded it again.
It worked for a while then the same thing happened. So, I repeated the procedure again and as of right now, it's working...except it still will not load my old svg files I created earlier on Inkscape.

Thanks,
Pat

Bryce Harrington (bryce) said : #3

I don't understand what you mean by, "I click on tool icons, the icon comes up but will not function". Can you please clarify?

pat gibbs (patgb) said : #4

For instance, I click on the pencil icon and the cursor shows up as the pencil icon...it can move around but won't do anything like draw lines when you left click...

pat gibbs (patgb) said : #5

For instance, I click on the pencil icon and the cursor shows up as the pencil icon...it can move around but won't do anything like draw lines when you left click...

prkos (prkos) said : #6

Maybe the layer you're working on is locked, look in the left bottom corner to check, click on the padlock icon to unlock it

ani (njani) said : #7

i having a problem that seems similar to the issue described by pat gibbs... specifically, i select a tool to use (e.g., ellipse), then drag the chosen tool within the document... but nothing seems to happen. for example, i try to draw with the pencil tool, but no line is created... i try to draw a spiral, but no spiral is created... the layer is not locked. the problem started with 0.45.1 so i uninstalled 0.45.1 and installed 0.46 in its place. and i'm using windows xp...

thank you in advance for any suggestions you might have.

ani (njani) said : #8

quick follow-up:
i found the problem i was experiencing was not with inkscape... rather, i needed to replace my mouse... (just f.y.i.)

Donawanda (donnazed1) said : #9

I am having the same problem, I can click on the toolbox, however I can't draw anything. I have replaced the batteries in my mouse.

braynpower (bryan-morris) said : #10

You could try this:

Goto Inkscape setup (Shift+Ctrl+P), select the Mouse options, and uncheck "use pressure sensitive tablet".... Restart Inkscape. It worked for me. If it doesn't work for you, I'm sorry. I have absolutely no idea what it could be otherwise.... Good luck! I was frustrated by this problem for quite some time, which led me to stop using the program. wasn't too happy, but now it's all good again, i'm happy, well as happy as someone who has to work for a living but hey... could be worse.

bacc (sesapj) said : #11

I want to thank you very much for posting this. braynpower's solution worked.
I think that the developers should have that box UNchecked by default.

Can you help with this problem?

Provide an answer of your own, or ask pat gibbs for more information if necessary.

To post a message you must log in.