can't change window size in 0.46 gutsy's svn snapshot

Asked by Ahmad Dendi Dwipayana on 2008-01-13

I tried 0.46 svn snapshot for gutsy that is posted at the inkscape's homepage on january 5th. I can't maximize the window using the MAXIMIZE/UNMAXIMIZE button in the upper corner, but i can resize it by dragging the window.

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2008-01-13
Last reply:
2008-02-01

It looks like i can use the maximize button, if i hide the desktop panels..

Bryce Harrington (bryce) said : #2

Hi Ahmad,

Yes, the problem is that due to the size of Inkscape's toolbars, it forces a restriction on the minimum height and width that Inkscape can be made. If your screen resolution is below that size, Inkscape may not maximize/minimize properly. Unfortunately I don't know of any easy workaround to solve it, however it's something the team has been working on and hope to have a good solution to in the future.

Bryce Harrington (bryce) said : #3

It's been some time since this question was answered, but as there hasn't been a response it's uncertain if your issue was successfully resolved. I'm marking it Solved, but if the issue still exists please do re-open it and explain where additional help is needed.

Bruce Westfall (brucewestfall) said : #4

If you detach the side toolbar, you can slide it off to the left side of the screen. Once the toolbar is out of the way, you can drag and resize the main window.

Since the bottom of the main window is blocked, press <ALT> and click and drag anywhere on the screen to move it. I'm using Ubuntu, and I'm not sure if the <ALT> trick works elsewhere...

Not the prettiest, fastest way to fix it, but it works on my laptop.

Pepo (instalcoma) said : #5

I am using Ubuntu Hardy 64 Bits on a Core Quad & Nvidia system and its impossible for me to maximize Inkscape in any resolution, If I detach side toolbar I can maximize it but I can use anymore the toolbar. I make toolbar visible on the screen the problem persist.

Any suggestion??

Pepo (instalcoma) said : #6

I tried this: (suggested in tiher forums)

Go to Pref --> misc

and mark the option " make toolbar icons smaller"

It works fine for me in Ubuntu Hardy 64 Bits, 1440x900 resolution on my Nvidia GT7600

Vaclav Manena (vaclav-manena) said : #7

1. Resize the window manually.
2. In Inkscape's preferences choose Windows > Remember and use last window's geometry.
3. Next time you run Inkscape it should work as expected.

victor_charlie (fullblastus) said : #8

[Ubuntu Ubuntu 8.10 - the Intrepid Ibex, 64-bit]
[Inkscape vers. 0.46-dev, built from source files]

I do get Inkscape Preferences, with a lot more options, including the ability to use the above suggestion to mark toolbar icons to small.

Not so with the Ubuntu Repositories version of 0.46. Nothing I can do will allow me to resize the Inkscape window to gain the horizontal scrollbar and the Info Panel across the bottom with mouseLocation X: Y:

I built 0.46-dev to gain JavaFX export (and it appears to be a better Inkscape).