Kerning doesn't work.

Asked by lodenmuse on 2008-01-09

I've read the "Why does manual kerning not work?" post and the answer, and it doesn't solve a thing for me. Trying to unflow doesn't change anything, or do anything different.

I'm using Leopard 10.5.1 and thought Inkscape was going to be wonderful.

It's just sort of frustrating right now.

(I even hunted and found a recommendation to "unselect the 'emulate three button mouse' option in X11 if having trouble with alt+ functions in OS X. Checked, and it's not even selected.)

=^|

Question information

Language:
English Edit question
Status:
Answered
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2008-01-09
Last reply:
2009-10-17
lodenmuse (lodenmuse) said : #1

Ok, so after hunting around for answer, I stumble upon an obscure reference that says under Leopard's X11 only the RIGHT alt/option key performs as alt/option. Combine this with the fact that a lot of Inkscapes shortcuts use the Control key, using Inkscape on a Mac is going to be crazy cumbersome.

:^(

Tom Davidson (tjd-mit) said : #2

Marking question as answered--even though you didn't like the answer :)
See also the bug linked at the left under 'related bugs' for more discussion and history.

Dianne Cooper (rutabaga) said : #3

Get an "ansi keyboard". It worked for me

Andi Luke (andiluke) said : #4

I found this in the bug notes for the "Related Bug" & it worked for me, making the left option/alt key work as expected:

Use ~/.Xmodmap to remap keys under X11:

! Switch meta and control
keycode 67 = Meta_L
keycode 63 = Control_L
keycode 71 = Control_R
clear mod2
clear control
add mod2 = Meta_L
add control = Control_L Control_R

! Switch the left alt key to be alt
! and leave the other as Mode_switch, for accents
keycode 66 = Alt_L

So what I did, was create a file (using vi in Terminal) .Xmodmap in my home directory. If things go horribly wrong, I can always delete that file.

Can you help with this problem?

Provide an answer of your own, or ask lodenmuse for more information if necessary.

To post a message you must log in.