Selection problems of clipped copies

Asked by Gregor Shapiro

I am experienceing difficulty in selecting objects. What I click on is not what gets selected.
I have four copies of a clipped object. The clipping mask was a circle, the object that was clipped was a ring of 120 narrow wedges (clones) in a radial array each wedge was a clone and the original path was filled with a gradient fill. This resulted in a circular patch of wedges with linear gradient fill . The circular clipping mask had a diameter of about 1/4 the diameter of the 120 wedge radial array.
When I spread the four copies of the circular patch apart from each other, no matter which i tried to select with a mouse click, only the last copy became selected. I could however select any one i wanted with "Rubber band" select (but I could never get the rotation handles because a second select with rubber band did not work and the click select deselected and selected the last copy).
Hopefully this link goes to my Dropbox with the .svg in question:
https://www.dropbox.com/s/frjy2jbf00itgkg/Selection%20problems.svg

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Gregor Shapiro
Solved:
Last query:
Last reply:
Revision history for this message
su_v (suv-lp) said :
#1

Known issue with your (somewhat dated) version of Inkscape (0.48.1, based on the information in the SVG file), tracked in
- Bug #365458 “clip object selection glitch”
  <https://bugs.launchpad.net/inkscape/+bug/365458>

You can select clipped objects which are lower in z-order with 'Alt+click'. Another workaround is to group each clipped object (also described in the comments of above bug report).

The bug is fixed in the latest bug-fix release 0.48.3.1 and in current trunk.

Revision history for this message
Gregor Shapiro (gregor-shapiro) said :
#2

The Alt+ Click does indeed help!