I've downloaded, and have been using Inkscape for the past several weeks. At first it worked well, but now, I can't save files. Please help...thanks

Asked by Richard E. Wentzel on 2012-11-03

I can't save files.

Question information

Language:
English Edit question
Status:
Answered
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2012-11-04
Last reply:
2012-11-10
su_v (suv-lp) said : #1

> I can't save files.

If you are using the Windows port of Inkscape 0.48.2, your problem very likely has been triggered by opening/saving files from/to the root of a drive, a known bug in Inkscape 0.48.2. on Windows, tracked in
- Bug #805095 "no File->Save As... dialog box if previously opened a file from root directory of a drive"
  <https://bugs.launchpad.net/inkscape/+bug/805095>

You can …

… download and install Inkscape 0.48.3.1 (which has this bug fixed) from
<http://sourceforge.net/projects/inkscape/files/inkscape/0.48.3.1/>
(this latest bug-fix release has not yet been officially announced because we are waiting for the packages for other platforms to be available first)

… or reset the preferences to default values (quit Inkscape, delete or rename "%APPDATA%\inkscape\preferences.xml", launch Inkscape again), and avoid saving or opening files from the root of a drive as long as you work with Inkscape 0.48.2 on Windows.

… or open a file _not_ in the root of a drive via context menu of the explorer in Inkscape ('Open with Inkscape…'), save it again after a small edit, save it as (with a new file name), and save a copy as (to reset the paths stored in the preferences file for the various save operations), and after that avoid saving or opening files from the root of a drive as long as you work with Inkscape 0.48.2 on Windows.

Linking as duplicate to bug #805095 - please add a comment here and revert the duplicate status if you don't agree and think these are different issues.

su_v (suv-lp) said : #2

<off-topic>
Oops - please ignore the last sentence of the previous reply (about the duplicate status) - I should have reread the draft more thoroughly and removed the parts which only are relevant to reports in the bug tracker, but not to questions in the 'Answers' section.
</off-topic>

Richard E. Wentzel (rewentzel) said : #3

Thanks, I did download the later version, and it fixed the problem.

On Sun, Nov 4, 2012 at 4:11 AM, ~suv
<email address hidden>wrote:

> Your question #213136 on Inkscape changed:
> https://answers.launchpad.net/inkscape/+question/213136
>
> ~suv proposed the following answer:
> <off-topic>
> Oops - please ignore the last sentence of the previous reply (about the
> duplicate status) - I should have reread the draft more thoroughly and
> removed the parts which only are relevant to reports in the bug tracker,
> but not to questions in the 'Answers' section.
> </off-topic>
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/inkscape/+question/213136/+confirm?answer_id=1
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/inkscape/+question/213136
>
> You received this question notification because you asked the question.
>

--
Richard E. Wentzel
Senior NVH Engineer
Wuxi Jixing Acoustic Auto Parts Co.,Ltd.
6294 Ginafred Shores Dr. SW
Fife Lake, MI 49633

Cell USA: 248-310-3903
e-mail: <email address hidden>
Cell China: 86-13961766809

su_v (suv-lp) said : #4

Would you mind closing the question (use e.g. one of the links provided in the notification mails you had received)? This will mark the question as 'Solved', which will be useful for those seeking answers to a similar question as well as for those trying to provide answers to questions which are still 'Open'.

shaju (chattukam) said : #5

The program may have corrupted by beginner attempts . un-install ,and reinstall ink scape may fix the issue

su_v (suv-lp) said : #6

@shaju - no, that was not the problem. Richard encountered a known regression with the Windows port of Inkscape 0.48.2, which is solved in the newer bug-fix release 0.48.3.1.

Can you help with this problem?

Provide an answer of your own, or ask Richard E. Wentzel for more information if necessary.

To post a message you must log in.