Bezier paths and handles not rendering (fully)

Asked by C. Toledo on 2012-10-26

I made a screen capture showing the issue: http://www.youtube.com/watch?v=j9vsA1SVkBg

The normal red line/handles that show when making a bezier path aren't showing since my last update on Arch Linux.
I tried downgrading to an older version, but the problem persisted, so the bug probably isn't with the Inkscape code, but with a dependency. What should I look into downgrading to see if I can track down why this is happening?

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
C. Toledo
Solved:
2012-10-26
Last query:
2012-10-26
Last reply:
C. Toledo (uberscientist) said : #1

I just ran another systemwide update today, and the problem is fixed!

Thanks, problems and fixes happen so fast in the Arch [testing] repo.

su_v (suv-lp) said : #2

> the bug probably isn't with the Inkscape code, but with a dependency.

Cairo 1.12.4 introduced some issues with Inkscape 0.48.3.1 (e.g. wrt handles of the pen tool, and outline view mode), and cairo 1.12.6 released a few days later tries to address them.

Just curious - with cairo 1.12.6 on Arch Linux, does outline view mode work for you again, or are the outlines still invisible?

C. Toledo (uberscientist) said : #3

Outlines are still invisible, I haven't used that mode before. I'm willing to do any more tests if it'll help :)

su_v (suv-lp) said : #4

The problem has been filed for cairo here:
<https://bugs.freedesktop.org/show_bug.cgi?id=56099>

So far, there have been no further comments by the cairo developers (after the release of 1.12.6) about outline view mode in Inkscapeā€¦

C. Toledo (uberscientist) said : #5

Ah-ha, I see. Thanks for keeping on them. Hopefully someone can give some explanation as to what they mean... maybe by sensible they mean integer? I don't know enough to guess...