glibc error when running inkscape

Asked by afk47 on 2007-12-31

$ inkscape
inkscape: Symbol `_ZTIN3Gtk6WidgetE' has different size in shared object, consider re-linking

(inkscape:21174): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
*** glibc detected *** free(): invalid pointer: 0x085bed50 ***

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.

Downloaded the inkscape-0.45.1-i486-1sl (13272 kB) (Slacky) version using swaret.
OS is Slackware 11, kernel is 2.6.17.13.

Tried to compile the new version, got the same error.

Any help much appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2008-01-01
Last reply:
2008-02-01
Bryce Harrington (bryce) said : #1

This sounds similar to an issue that was common on gentoo and slackware a while ago - if you've compiled inkscape and your system's C++ libraries (gtkmm, glibmm, libsigc++, etc.) using different versions of gcc, then they can be linked with different incompatible C++ ABI's. The program will build and link, but then inkscape will crash at launch with error messages mentioning glibc, gtkmm, or sigc. The typical solution is to just rebuild each of those libraries, then rebuild Inkscape.

Note that the first Gtk-WARNING line is unrelated and can probably be ignored.

afk47 (asdffg12) said : #2

What do you mean by 'rebuild' ?

Bryce Harrington (bryce) said : #3

by rebuild I mean recompile those libraries. I've not used Slackware so don't know the commands for doing that. Since you're a Slackware user I assume you know how to rebuild packages...

Bryce Harrington (bryce) said : #4

It's been some time since this question was answered, but as there hasn't been a response it's uncertain if your issue was successfully resolved. I'm marking it Solved, but if the issue still exists please do re-open it and explain where additional help is needed.