python in Windows 7: "The fantastic lxml wrapper for libxml2"

Asked by Daniel Maxwell on 2012-08-16

Using Inkscape in Windows 7, I get this bug when I try to use some of the extensions (eg. 'Color Markers to Match Stroke'):

"The fantastic lxml wrapper for libxml2 is required by inkex.py and therefore this extension. Please download and install the latest version from http://cheeseshop.python.org/pypi/lxml/, or install it through your package manager by a command like: sudo apt-get install python-lxml"

There is a lot of talk about this bug in the forums, all of it relating to OSX. I am not running OSX, I'm running 64-bit Windows 7, and I have not found any solutions for it.

I have verified that the lxml folder IS present, in location: "C:\Program Files (x86)\Inkscape\python\Lib\site-packages\lxml"

Python is installed separately on my machine, and is in the environment variables - which I suspected might have been the problem but deleting it from the variables and restarted the machine did not solve the problem.

Any other suggestions??

Question information

Language:
English Edit question
Status:
Open
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2012-08-16
Last reply:
Daniel Maxwell (cot) said : #1

I have found a work around, but not a satisfactory solution.

It was caused by a previous installation of Python, which had installed an environment variable called PYTHONHOME in the system variables. Deleting this variable solved the problem. This isn't at all a satisfactory solution, because whatever it was that was previously using that environment variable now can't, but at least it makes Inkscape work.

He is how to get rid of it:
- From the Start menu, type "System" and select System from the list (under 'Control Panel').
- Click on 'Advanced System Settings' from the panel on the left.
- Click the 'Environment Variables' button at the bottom.
- Under 'System Variables', scroll down until you find a variable called 'PYTHONPATH', write down what its value is, so that you can recreate it if you need it, and then delete it.
-Close and open Inkscape, and try to see if it's worked. (There was no need to restart the computer in my case).

Hope that helps other people.

This still needs a proper fix to make Inkscape work without having to do this.

Can you help with this problem?

Provide an answer of your own, or ask Daniel Maxwell for more information if necessary.

To post a message you must log in.