Inkscape: A Vector Drawing Tool

How do I change Inkscape's default template (e.g. paper size, ruler units, etc.)

Asked by mikepav on 2007-12-19

Many countries such as the one I live in switched to the metric measuring system as far back as the 1960's, so most of the people using this software are lost as soon as they encounter the imperial rulers and system of measurement.

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Bryce Harrington
Solved:
2007-12-30
Last query:
2007-12-30
Last reply:
2007-12-29
Ryan Lerch (ryanlerch) said : #1

It is possible to change the units of measure that are used in a document. This is done via File > Document Properties. (the default units setting is the one to change...)
There are many different units of measure in there to choose from. (pixels, centimetres, millimetres, metres, feet, inches...)

Remember though, this is a document setting, so each document has it's own default units setting. If you want every new document that you create to have the same setting, you will have to change your default template to reflect this.

mikepav (pcpavnz) said : #2

Thanks for the reply. It looks like the change can be made permanent, which
is what I really need because nobody in this part of the world uses imperial
measurements.Can you please tell me where the default template should be
stored on a Debian Linux system?

Kind regards

Mike P

On Dec 20, 2007 11:21 AM, Ryan Lerch <email address hidden>
wrote:

> Your question #20347 on Inkscape changed:
> https://answers.launchpad.net/inkscape/+question/20347
>
> Status: Open => Answered
>
> Ryan Lerch proposed the following answer:
> It is possible to change the units of measure that are used in a document.
> This is done via File > Document Properties. (the default units setting is
> the one to change...)
> There are many different units of measure in there to choose from.
> (pixels, centimetres, millimetres, metres, feet, inches...)
>
> Remember though, this is a document setting, so each document has it's
> own default units setting. If you want every new document that you
> create to have the same setting, you will have to change your default
> template to reflect this.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/inkscape/+question/20347/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/inkscape/+question/20347
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
----------
Did you know that gmail is a Linux product? If you're using gmail or any
google product at all, you are using and benefiting from Linux technology.

Linux is available for your desktop, it's free, it's secure and it really
easy to use. Why not head over to http://www.mepis.com and learn how you can
switch to Linux while still using windows. If you can successfully use Linux
for a week, you'll realize just how much time and resources you really waste
with windows, just trying to keep it safe and secure.

vonHalenbach (lustik) said : #3

Please don't spam the answer tracker with your advertising. Especially on christmastime i find such behavior cheeky. Thank you for listening.

mikepav (pcpavnz) said : #4

My humble apologies, I was not trying to be cheeky. My only intention was to seek further information regarding inkscape, which I have recommended to hundreds of people since I first discovered it. I was responding to the email directly from my gmail account because I saw the following lines regarding feedback in the email
If you still need help, you can reply to this email or go to the
following page to enter your feedback:
So that's what I did, I responded directly from my gmail account as if using email, completely unaware of the impact of my signature text that is automatically appended to the end of all emails and that I totally forgot was even there! Since I have had gmail, I have only sent 31 emails in total, some of them were conversations and I've had and I joined in October 2005 so I am not a spammer!

Maybe this is an opportunity to add a precursory note to the feedback line regarding signature files and their impact, rather than flaming me for an action that was done in complete ignorance, therefore I am innocent of any deliberate act of spamming. I am not associated with Mepis, it is just my favorite distribution

Now that this issue has forked, how about a moderator step in and edit out my innocent mistake and stop this out of place flaming because it has left a sour taste in my mouth for a program I really like and have promoted much.

Mike P

Best Bryce Harrington (bryce) said : #5

All of Inkscape's stock stuff is stored in /usr/share/inkscape/. So to configure the default template on debian, you'd do something like this:

 sudo inkscape /usr/share/inkscape/templates/default.svg

Then go to File > Document Properties, make the alterations (such as units) you'd like to have set for all documents, save, and exit.

Bryce

mikepav (pcpavnz) said : #6

Thanks Bryce Harrington, that solved my question.

Users with localized versions (not english) have to edit the proper template for their language.
For instance for spanish I had to edit /usr/share/inkscape/default.es.svg

Ryan Lerch (ryanlerch) said : #8

For the windows user's out there, the inkscape share directory is inside your main inkscape directory. The usual place for this is:
C:\Program Files\Inkscape\share\

DannyB (danny-sunflower) said : #9

If you want Inkscape to always start out with a document with particular settings, document size, window placement, etc., then create a document that is exactly what you want and then save it with the name...

/home/danny/.inkscape/templates/default.svg

You can even have pre-drawn items in this document. Or layers pre-setup. Or special gradients already added to the document. Or other possibilities.

Alvin Penner (apenner) said : #10

thanks, you answered my question before I even spoke it

jean.sellers (jean-sellers) said : #11

It worked! This will save me lots of frustration. Thanks.

Apteryx (maxco) said : #12

This didn't work for me on Karmic : ~/.inkscape/templates/default.fr.svg. (My localization is fr_CA). I had to replace the /usr/share/inkscape/default.fr.svg.

Brett (this-is-spam-mail) said : #13

On mac default.svg is located at:
/Applications/Inkscape.app/Contents/Resources/templates/default.svg

ℵ (zeta-function) said : #14

Why don't we make it the default behavior to reflect all changes to Document Properties?

Most people wouldn't know the existence of the local templates directory (or the global for that matter); and current behavior is not at all intuitive.

Creating the ~/.inkscape/templates/default.svg did not work. Changing the /usr/share/inkscape/templates/default.svg did work. Inkscape 0.47 on Ubuntu Lucid 64bit. This is troubling because an update will possibly break the edited default.svg since it is in the program's directory instead of the user's.

I am trying to default to letter and inches instead of A4 and pixels. Creating a /etc/paper with letter in it did not change the default from A4 to letter as suggested in another thread.

Raumkraut (raumkraut) said : #16

At some point Inkscape changed its user-config file locations to match the freedesktop.org standards. Hence, to change the per-user default document, the file you now need to create is: ~/.config/inkscape/templates/default.svg

This works perfect, thanks!

Where do I find ~/.config?

The tilde character (~) is shorthand on the command line shell for /home/yourusername, or your home directory. If you are file browsing, just open the home directory > go to View-Show Hidden Files. The .config directory will appear and you can edit, create or save the default file as described.

Perfect- Thanks

On Thu, Jun 16, 2011 at 18:25, Bingo Tailspin <
<email address hidden>> wrote:

> Question #20347 on Inkscape changed:
> https://answers.launchpad.net/inkscape/+question/20347
>
> Bingo Tailspin posted a new comment:
> The tilde character (~) is shorthand on the command line shell for
> /home/yourusername, or your home directory. If you are file browsing,
> just open the home directory > go to View-Show Hidden Files. The
> .config directory will appear and you can edit, create or save the
> default file as described.
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Gregor Shapiro
Lasarettsvägen 11
SE 302 33 Halmstad Sweden
0046 (0)73 976 2989

mikepav (pcpavnz) said : #21

~/ is the linux users way of saying your home folder and the

On 17/06/2011 4:17 AM, "Gregor Shapiro" <email address hidden>
wrote:

Your question #20347 on Inkscape changed:
https://answers.launchpad.net/inkscape/+question/20347

Gregor Shapiro posted a new comment:
Where do I find ~/.config?

--
You received this question notification because you asked the question.

Jeffrey Watson (jwatson934) said : #22

I am using Inkscape with my Mac. I was wondering if there is any way to have the default template open with Fill & Stroke, Layers and Align and Distribute already set up on the page. I have tried making a new default with those on and then saving it as the default template but when I open a new default they are no longer there.
Thanks in advance,
J. Watson

~suv (suv-lp) said : #23

@Jeffrey Watson - Inkscape cannot save the state of dialogs between sessions. This feature request is tracked in
Bug #171579 in Inkscape: “Make inkscape remember dialogs window status”
<https://bugs.launchpad.net/inkscape/+bug/171579>
and currently being worked on (possibly available in the next major release).