Inkscape: A Vector Drawing Tool

Inkscape crashes, "X11 quit unexpectedly."

Asked by jay tee on 2012-04-08

I'm on a Mac with 10.6.8 Snow Leopard.

I can open both new and existing Inkscape drawings but as soon as I go to change something, it crashes and closes and I get the error report "X11 quit unexpectedly." I've uninstalled and re-installed both X11 and XQuartz several times. I've also uninstalled and re-installed Inkscape... I just realized the same thing happens with GIMP, so this is probably a question for an X11 forum. The xQuartz version is 2.7.2_beta4. The latest version of X11 that I'm trying is 2.3.1. Any experience with this?

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
~suv
Solved:
2012-04-08
Last query:
2012-04-08
Last reply:
2012-04-08
Best ~suv (suv-lp) said : #1

> The xQuartz version is 2.7.2_beta4

Known issue in the latest XQuartz beta4 - downgrade to current stable XQuartz 2.7.1 until a newer version of XQuartz is available

See also:
Bug #972914 "[OS X] Crash when clicking inside drawing area with XQuartz 2.7.2 beta4"
<https://bugs.launchpad.net/inkscape/+bug/972914>

~suv (suv-lp) said : #2

> The latest version of X11 that I'm trying is 2.3.1

Of the XQuartz releases you can download from
<http://xquartz.macosforge.org/trac/wiki/Releases>
you need at least v2.5.1 or later to be able to launch and use Inkscape 0.48.2.

jay tee (trailspark) said : #3

Thanks ~suv, that solved my question.