" Measure path" gives an error message in Lion

Asked by Jan-Willem on 2011-10-17

Dear reader,

I made the step from Windows to MAC. I work with Lion. When I use the Extension " Measure Path" I get the following message:

The fantastic lxml wrapper for libxml2 is required by inkex.py and therefore this extension. Please download and install the latest version from http://cheeseshop.python.org/pypi/lxml/, or install it through your package manager by a command like: sudo apt-get install python-lxml

But python is still on my system.

What can I do to resolve this problem?

Best regards,

Jan-Willem Rommerts

Question information

Language:
English Edit question
Status:
Answered
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2011-10-17
Last reply:
2011-10-17
su_v (suv-lp) said : #1

Unfortunately, python-based extensions don't work with the official osx package (Inkscape 0.48.2) on Lion yet:
the issue is known and tracked in

Bug #819209 in Inkscape: “Extensions do not work with Mac OS X Lion”
<https://bugs.launchpad.net/inkscape/+bug/819209>

su_v (suv-lp) said : #2

> But python is still on my system.

The issue is not that your python mysteriously disappeared - the underlying and not yet address problem is that Apple upgraded the default system python to 2.7 (and the Inkscape application bundle does not yet include the required modules for python 2.7 nor does it force the use of python 2.6 (32bit) when calling python from inside Inkscape.app).

Jan-Willem (jwr-rom) said : #3

Thanks for the quick response! Must have to wait for a new update of Inkscape.

Can you help with this problem?

Provide an answer of your own, or ask Jan-Willem for more information if necessary.

To post a message you must log in.