Inkscape: A Vector Drawing Tool

How to Reset Default Settings for 3D Tool

Asked by K.P. on 2011-05-28

Hi,

I'm using Ubuntu 10.10 and Inkscape 0.48. I was experimenting with the 3D tool and its preferences to try to change the color of the fill and to give it a stroke that would be easier to see. The preferences refused to take but kept changing to wonky settings the more I fooled with the 3D tool, to the point that the default figure is something I cannot modify properly. Now I'd just like my original 3D settings back so I can get a normal rectangular prism. I don't want to reset all of Inkscape's default settings, though. Is there a way to do this? If there's not a "reset default" button, can I at least enter in some manual values somewhere in Inkscape?

Thanks so much!

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
~suv
Solved:
2011-05-28
Last query:
2011-05-28
Last reply:
2011-05-28
Best ~suv (suv-lp) said : #1

Please try these steps to delete the 'current style' settings for individual faces of new 3d boxes:
1) quit Inkscape
2) open '~/.config/inkscape/preferences.xml' in a plain-text editor
   (keep a backup copy to be able to revert to the previous state)
3) search for these settings:

    <group
       id="XYfront"
       style="fill:#00ff00" />
    <group
       id="XYrear" />
    <group
       id="XZtop" />
    <group
       id="XZbottom" />
    <group
       id="YZleft" />
    <group
       id="YZright" />

4) simply delete the lines or remove the style attribute for those you no longer want to have a special style
5) save the preferences file and relaunch Inkscape

Alternatively you can change the tool preferences of 3d boxes to 'Use tool's own style' (in the Preferences dialog), to avoid that the last used style of individual faces is reused.

K.P. (kkolode) said : #2

Thank you so much!

K.P. (kkolode) said : #3

Thanks ~suv, that solved my question.

K.P. (kkolode) said : #4

By the way, "Use tool's own style" was not sticking - that was part of what was frustrating me. It wouldn't actually use the "take from selection" settings, though they appeared in the Preferences box. Not right away, not in a new document, not after quitting Inkscape, not after restarting computer, etc. Felt very buggy.